Login nach update von 4.4 auf 4.6

Gesperrt
Uwe
Beiträge: 258
Registriert: Mo 30. Jun 2003, 16:05
Wohnort: Konstanz
Kontaktdaten:

Login nach update von 4.4 auf 4.6

Beitrag von Uwe » Mo 29. Okt 2007, 15:05

Hallo,

eine Frage, die möglicherweise schon gestellt wurde. Habe aber leider die Antwort nicht gefunden, wenn mit jemand unter die Arme greifen könnte ...

In der Version 4.4 werden geschützte Seiten angezeigt, wenn sich ein User einloggt, der unter Benutzer angelegt worden ist. In der Version 4.6 funktioniert das bei den Frontendusern. Nun habe ich eine Version 4.4.4. upgedatet auf Version 4.6.22. Mit bestehendem Login-Modul (Standardmodul) haben die User keinen Zugang mehr zum geschützten Bereich. Der Login an sich funzt noch, aber die geschützten Seiten dürfen nicht mehr betreten werden.

Gibt es hier eine Möglichkeit, ohne die User in Frontenduser zu verwandeln, so dass es wieder funktioniert?

Vieel Grüsse vom sonnigen Bodensee, Uwe

risibility
Beiträge: 89
Registriert: Fr 25. Feb 2005, 00:13
Wohnort: Darmstadt
Kontaktdaten:

Beitrag von risibility » Di 30. Okt 2007, 10:30

Hallo Uwe,

hast du mal geschaut ob die Benutzer die entsprechenden Rechte unter Kategorie -> Frontend-Zugriff haben?

Gruß
Ris

EDIT: Sorry, kann es leider nicht sein, hab es getestet... Vielleicht hat jemand anderes einen Vorschlag.
Contenido Version: 4.8.3
Apache 1.3.34
MySQL Serverversion 5.0.32
Installierte PHP-Version 5.2.5

Uwe
Beiträge: 258
Registriert: Mo 30. Jun 2003, 16:05
Wohnort: Konstanz
Kontaktdaten:

Beitrag von Uwe » Di 30. Okt 2007, 10:59

Hallo,

vielen Dank für Deinen Tipp.

Die User sind NICHT unter Frontendusern eigetragen, sondern bei den Benutzern (Redakteure etc.)

Die Frage ist, ob ich die gleiche Funktionalität, wie unter Version 4.4. bekommen kann. Also, dass Benutzer, die bei "Benutzer" eingetragen sind und nicht bei "Frontenduser", sich einloggen können und Zugriff auf geschützte Seiten bekommen.

Viele Grüsse aus Konstanz, Uwe

Oldperl
Beiträge: 4086
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Beitrag von Oldperl » Di 30. Okt 2007, 11:49

Hallo Uwe,

da existiert ein Bug :arrow: http://contenido.org/forum/viewtopic.php?t=18291

Dieser verhindert unter gewissen Vorraussetzungen das Einbinden der, für die Frontentberechtigung zuständigen, Chain.

Du bekommst dann zwar angezeigt, das du eingelogt bist, hast aber keinen Zugriff auf die Kategorie, bzw. wirst auf die Fehlerseite umgeleitet, da die Berechtigungen aus der DB nicht eingelesen wurden.

EDIT: Achja, du musst die User in den Frontendberechtigungen anlegen, das ist getrennt.

Gruß aus Franken

Ortwin
CONTENIDO 4.9 Entwickler-Handbuch - Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

HerrB
Beiträge: 6935
Registriert: Do 22. Mai 2003, 12:44
Wohnort: Berlin
Kontaktdaten:

Beitrag von HerrB » Mi 31. Okt 2007, 21:09

Was man alles beachten muss:

a) Wenn es ein Update einer V4.4.x-Version ist, muss insbesondere darauf geachtet werden, dass das plugins-Verzeichnis der Version aus V4.6.x entspricht.
b) Backend-Accounts werden nicht mehr für den Frontend-Zugriff beachtet, sie sind zu migrieren (siehe Tips&Tricks V4.6.x).
c) Das, was oldperl schrieb.
d) Die Navi-Module sollten aktualisiert werden, damit die geschützten Kategorien beachtet und ggf. nicht mehr angezeigt werden.
e) Die neuen Navi-Module benötigen einige Zusatzdateien unter Mandantenverzeichnis/includes, siehe aktueller Beispielmandant.

Gruß
HerrB
Bitte keine unaufgeforderten PMs oder E-Mails -> use da Forum!

Newsletter: V4.4.x | V4.6.0-15 (Module, Backend) | V4.6.22+
Standardartikelliste: V4.4.x | V4.6.x
http://www.contenido.org/forum/search.php | http://faq.contenido.org | http://www.communido.net

Gesperrt