OXID2CON - Fehler bei Konfiguration in Contenido

Alles rund um Module und Plugins in CONTENIDO 4.9.
Antworten
stephan1978
Beiträge: 1
Registriert: Mo 25. Apr 2016, 07:50
Kontaktdaten:

OXID2CON - Fehler bei Konfiguration in Contenido

Beitrag von stephan1978 » Mo 25. Apr 2016, 08:24

Hallo,

ich möchte das OXID Modul "OXID2CON"
http://exchange.oxid-esales.com/en/Syst ... 5-2-x.html
gern installieren.

Leider funktionieren in CONTENIDO 4.9.9 die Einstellungen zum SOAP (unter Extras > SOAP) nicht. Es erscheint nur eine leere Seite. Das Modul "Smarty Wrapper 1.0.0" ist installiert und aktiviert.

In den Logs ist folgende Ausgabe zu sehen:
[25-Apr-2016 09:19:16 Europe/Berlin] PHP Fatal error: Class 'Contenido_SmartyWrapper' not found in /home/public_html/public/contenido/contenido/plugins/soap/classes/class.soap.gui.php on line 256
[25-Apr-2016 09:19:16 Europe/Berlin] PHP Stack trace:
[25-Apr-2016 09:19:16 Europe/Berlin] PHP 1. {main}() /home/public_html/public/contenido/contenido/main.php:0
[25-Apr-2016 09:19:16 Europe/Berlin] PHP 2. include_once() /home/public_html/public/contenido/contenido/main.php:203
[25-Apr-2016 09:19:16 Europe/Berlin] PHP 3. SoapRightBottomPage->__construct() /home/public_html/public/contenido/contenido/plugins/soap/includes/include.soap_right_bottom.php:20
[25-Apr-2016 09:19:16 Europe/Berlin] PHP 4. SoapRightBottomPage->renderForm() /home/public_html/public/contenido/contenido/plugins/soap/classes/class.soap.gui.php:56


Wie gesagt, dass Modul "Smarty Wrapper 1.0.0" ist installiert und aktiviert.

Wie kann ich den Fehler beheben?

Viele Grüße
Stephan

Oldperl
Beiträge: 4085
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Re: OXID2CON - Fehler bei Konfiguration in Contenido

Beitrag von Oldperl » Do 28. Apr 2016, 07:54

Servus Stephan,
stephan1978 hat geschrieben:In den Logs ist folgende Ausgabe zu sehen:
[25-Apr-2016 09:19:16 Europe/Berlin] PHP Fatal error: Class 'Contenido_SmartyWrapper' not found in /home/public_html/public/contenido/contenido/plugins/soap/classes/class.soap.gui.php on line 256...
Du hast da 2 Mal 'contenido' im Pfad, das kann zu Fehlern beim Includieren der Klassen führen (ich glaube sogar da gibt es noch einen Bug). Versuch doch erst mal, bevor man genauer schaut, ob es schon funktioniert wenn du deinen root-Ordner umbenennst.

Gruß aus Franken

Ortwin
CONTENIDO 4.9 Entwickler-Handbuch - Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

alexander_scheider_4fb
Beiträge: 2
Registriert: Fr 22. Feb 2013, 11:11
Kontaktdaten:

Re: OXID2CON - Fehler bei Konfiguration in Contenido

Beitrag von alexander_scheider_4fb » Mo 2. Mai 2016, 07:00

Hallo Stephan,

die Klasse "Contenido_SmartyWrapper" existiert seit CONTENIDO 4.9.7 nicht mehr.
Deswegen tritt dieser Fehler bei dir auf.
Die Anpassung am Plugin wurde bereits durchgeführt, das Plugin ist aber leider noch nicht im Exchange hochgeladen.
Wenn du magst kann ich dir gerne die neuere Version per E-Mail zusenden.

Viele Grüße,
Alexander

Antworten