Parse Error bei Apostroph (')

Fragen zur Installation von CONTENIDO 4.9? Probleme bei der Konfiguration? Hinweise oder Fragen zur Entwicklung des Systemes oder zur Sicherheit?
Antworten
CinKon
Beiträge: 129
Registriert: Do 9. Okt 2008, 09:13
Wohnort: Leipzig
Kontaktdaten:

Parse Error bei Apostroph (')

Beitrag von CinKon » Do 3. Mai 2018, 12:47

In der letzten Version 4.9.12 habe ich das Problem, wenn ich im CMS_HEAD oder CMS_HTML Text mit einem Apostroph speichere, bekomme ich nur diesen Fehler:

Code: Alles auswählen

Parse error: syntax error, unexpected 's' (T_STRING), expecting ',' or ';' in /contenido/includes/include.con_editcontent.php(523) : eval()'d code on line 15
Also Apostroph geht gar nicht... Datenbank-Schema ist utf8_general_ci...
"Marty, du musst VIERDIMENSIONAL denken!" - Doc Brown

rethus
Beiträge: 1816
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: Parse Error bei Apostroph (')

Beitrag von rethus » Mo 7. Mai 2018, 10:37

Du müsstest deine Module ggf. entsprechend anpassen, das dieses Zeichen 'escaped' wird.

http://php.net/manual/de/function.htmlentities.php
oder

http://php.net/manual/de/function.addslashes.php
und
http://php.net/manual/de/function.stripslashes.php

Ist aber seltsam, das dieses Problem bei dir auftritt, bei einer Standardinstallation hatte ich das bisher meines Wissens noch nicht.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

CinKon
Beiträge: 129
Registriert: Do 9. Okt 2008, 09:13
Wohnort: Leipzig
Kontaktdaten:

Re: Parse Error bei Apostroph (')

Beitrag von CinKon » Mo 14. Mai 2018, 15:34

Ich mach ja nichts außergewöhnliches, und eigentlich auch nur Standard-Installation...
An PHP7 kann das nicht liegen, oder?
"Marty, du musst VIERDIMENSIONAL denken!" - Doc Brown

rethus
Beiträge: 1816
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: Parse Error bei Apostroph (')

Beitrag von rethus » Mi 16. Mai 2018, 13:08

Könnte auch an deiner MySQL-Konfiguration liegen.
Schau mal hier: https://dev.mysql.com/doc/refman/8.0/en ... erals.html
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Antworten