[Bug 4.9.0] Wiedereinloggen im Backend nach Timeout

Fragen zur Installation von CONTENIDO 4.9? Probleme bei der Konfiguration? Hinweise oder Fragen zur Entwicklung des Systemes oder zur Sicherheit?
Antworten
derernst
Beiträge: 50
Registriert: Do 14. Aug 2008, 16:47
Kontaktdaten:

[Bug 4.9.0] Wiedereinloggen im Backend nach Timeout

Beitrag von derernst » Do 22. Aug 2013, 13:20

CONTENIDO Version 4.9.0
Webserver-Version Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9
Installierte PHP-Version 5.2.9
Datenbankserver-Version 5.1.33-community
PHP-Datenbankerweiterung mysqli

PHP-Einstellungen
date.timezone
include_path .;C:\xampp\php\pear\
memory_limit 32M
upload_max_filesize 64M
post_max_size 64M
max_execution_time 60
max_file_uploads
max_input_time 60
sql.safe_mode Deaktiviert
disable_classes nichts deaktiviert
disable_functions nichts deaktiviert

Hier noch ein seltsames Phänomen, wohl eine Kinderkrankheit der neuen Version: Wenn ich nach längerer Inaktivität im Backend etwas anklicke, ist meine Session ja abgelaufen, und ich gelange auf die Login-Maske. Mein Benutzername ist vorbelegt, ich gebe das Passwort ein und sende ab. Dann gelange ich zwar ins Backend, jedoch ist dieses auf Englisch, und der gesamte Kopf mit der Navigation ist weiss. Ich könnte also auf "Overview", "Reminder List" und "Settings", aber sonst kann ich nichts machen. Zumindest im Firefox hilft es auch nichts, die Cookies zu löschen - erst nach dem vollständigen Schliessen und Neustarten des Browsers kann ich mich wieder normal einloggen.

Falls dieses Problem auf euren PCs oder Browsern nicht reproduzierbar ist, oder falls es schwierig zu beheben ist, würde ein zusätzlicher Logout-Button direkt auf der Willkommensseite schon reichen, wenn er denn alle Sessions des Admins löscht.

Danke & Gruss
Markus

derernst
Beiträge: 50
Registriert: Do 14. Aug 2008, 16:47
Kontaktdaten:

Re: [Bug 4.9.0] Wiedereinloggen im Backend nach Timeout

Beitrag von derernst » Di 26. Nov 2013, 17:47

Passiert dies niemandem außer mir? Bei mir ist es jedesmal so wenn die Session abläuft. Ich muss den Browser ganz beenden, um wieder ins Contenido einloggen zu können. Wenn man grad viele Tabs offen hat, die man noch braucht, ist es recht nervig...

rethus
Beiträge: 1820
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: [Bug 4.9.0] Wiedereinloggen im Backend nach Timeout

Beitrag von rethus » Di 3. Apr 2018, 08:31

Ich habe mal etwas ähnliches beobachtet. Und zwar immer dann, wenn man einen Deep-Link ins Backend nutzt... also wenn in der Url noch einige Parameter (ggf. auch die alte Session-Datei) vorhanden ist.

Das Problem besteht schon länger, ist mir aber meist nur untergekommen, wenn ich in der Adress-Zeile des Browsers die URL einge, der Browser auf die letzte aufgerufene URL vervollständigt... und dies dann eine ist, wo die alten Parameter anhängen.

Versuche bitte mal folgendes:
  1. Logge dich ein und lass den Timeout greifen
  2. Schaue in die Adresszeile und kopiere die URL (z.B. in Text-Programm
  3. Lösche alle Parameter weg und achte darauf, das deine "default"-Backend URL (z.B. Domain/contenido/) in der Adresse steht und nicht Domain/logout oder ähnliches.
  4. Logge dich dann ein
Danach noch mal das gleiche, ohne die URL zu verändern
  1. Logge dich ein und lass den Timeout greifen
  2. Schaue in die Adresszeile und kopiere die URL (z.B. in Text-Programm (under den bereits bestehenden Eintrag vom vorherigen Versuch))
  3. Belasse die URL so wie sie war.
  4. Logge dich dann ein (sollte deinen beschriebenen Fehler produzieren)
Kannst dann ja hier mal berichten.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Antworten