[4.9.0-b1] DB-name mit "." oder "-" nicht (mehr) möglich

Fragen zur Installation von CONTENIDO 4.9? Probleme bei der Konfiguration? Hinweise oder Fragen zur Entwicklung des Systemes oder zur Sicherheit?
Antworten
bbdrummer
Beiträge: 18
Registriert: Fr 2. Mär 2007, 16:49
Wohnort: Hürth, Germany
Kontaktdaten:

[4.9.0-b1] DB-name mit "." oder "-" nicht (mehr) möglich

Beitrag von bbdrummer » Fr 16. Nov 2012, 11:39

mir ist es in 4.9 bisher nicht mehr möglich gewesen datenbanknamen in der form "con_4.9.0-beta1" zu verwenden (hat unter 4.8x noch funktioniert).
da landen dann SQL fehler im log á la "syntax error @ '.9.0-beta1'...", ich vermute das der db-name nicht immer konsequent in `...` eingeschlossen wird.
z.B. neue mandanten, sprachen, kategorien erhalten dann immer ID '0' bzw, werden teils gar nicht erst angelegt ("DUPLICATE KEY ENTRY" taucht dann in den logs auf)...

xmurrix
Beiträge: 2797
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: [4.9.0-b1] DB-name mit "." oder "-" nicht (mehr) möglich

Beitrag von xmurrix » Fr 16. Nov 2012, 12:26

Hallo bbdrummer,

mir ist nicht bekantn, dass in der 4.9 er Version der Datenbankname in einer SQL-Anweisung verwendet wird, die Datenbank wird je nach Adapter mit mysqli_select_db() oder mysql_select_db() ausgewählt und da braucht man keine back-ticks. Oder verwendest du etwa PDO? Falls ja, dann könnte das möglich sein...

Muss man sich genauer anschauen, auf jeden Fall vielen Dank für das feedback.

Grüße
xmurrix
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

Antworten