Übersicht Minimal- und Maximalanforderungen verschiedener Contenido Versionen

Nicht mit CONTENIDO unmittelbar zusammenhängende Themen, Lob und Kritik.
Antworten
lunsen_de
Beiträge: 252
Registriert: Mo 17. Okt 2005, 20:26
Wohnort: Weimar
Kontaktdaten:

Übersicht Minimal- und Maximalanforderungen verschiedener Contenido Versionen

Beitrag von lunsen_de » Fr 10. Jun 2022, 14:27

Hallo zusammen,

Da ich auf unserem Server mit dem Develop-Branch 4.10.1 an unsere Grenzen gestoßen bin, hoffe ich hier mit anderen Usern mal eine Übersicht zu schaffen unter welchen Servervoraussetzungen Contenido Versionen (problemlos) funktionieren.

Anlass ist, dass wir auf unserem Server einige Contendio Versionen am laufen haben, von 4.8 über 4.9 bis zur 4.10. Die PHP Versionen können wir für die Domains einstellen. Von PHP 5.6 bis hin zu PHP 8. Das läuft soweit alles super.
Allerdings läuft nur eine Datenbankversion (Maria DB 5.5) und damit stoßen wir jetzt an die Grenzen. Die DB Version zu updaten bedeutet für alle Account die neue Version und hier kommt das Problem, dass evtl. einige (ältere) Versionen nicht mehr laufen.
Daher die Idee zu sehen ob jemand z.B. eine 4.8 mit DB Version 5.6 oder 5.7 am laufen hat usw.

Also wir haben derzeit:
Contenido 4.8.19 mit PHP 5.6 und MariaDB 5.5
Contenido 4.9.12 mit PHP 7.0 und MariaDB 5.5
Contenido 4.10.1 mit PHP 7.3 und MariaDB 5.5 (testweise auch PHP 7.4)

Den aktuellen Develop-Branch bekomme ich wegen der älteren Datenbankversion nicht installiert. viewtopic.php?f=115&t=44468

Wäre super, wenn hier Erfahrungen zusammen kommen würden, welche Maximalvoraussetzungen Ihr laufen habt.

Grüße larslunsen

xmurrix
Beiträge: 3022
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: Übersicht Minimal- und Maximalanforderungen verschiedener Contenido Versionen

Beitrag von xmurrix » Fr 10. Jun 2022, 15:48

Hallo larslunsen,

bei mir sind folgende Konstellationen vorhanden:
  • CONTENIDO 4.9.7 mit PHP 5.6.40 und MySQL 5.7.37
  • CONTENIDO 4.9.8 mit PHP 5.6.40 und MariaDB 10.5.15
  • CONTENIDO 4.9.12 mit PHP 7.2.34 und MySQL 5.7.37
  • CONTENIDO 4.10.0 mit PHP 7.2.34 und MySQL 5.7.38
  • CONTENIDO 4.10.1 mit PHP 7.4.5 und MariaDB 10.4.11, SQL-Mode gesetzt (viewtopic.php?t=44136) mit einigen PHP Deprecated und PHP Warning Einträgen in der errorlog.txt
  • CONTENIDO GitHub develop-Branch (Stand 10.06.2022) mit PHP 7.4.5 und MariaDB 10.4.11
  • CONTENIDO GitHub develop-Branch (Stand 10.06.2022) mit PHP 8.0.18 und MariaDB 10.4.11
Mit Contenido 4.8 und MySQL 5.7 sehe ich keine Probleme, sofern man sicherstellt, dass die Verbindung nicht im strikten Modus läuft, also mit sql_mode='MYSQL40'. Ich würde das aber vorher sicherheitshalber testen.

Grüße
xmurrix

Faar
Beiträge: 1808
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: Übersicht Minimal- und Maximalanforderungen verschiedener Contenido Versionen

Beitrag von Faar » Sa 11. Jun 2022, 08:19

Ich weiß gar nicht, was alles bei Kunden läuft aber kleiner Auszug:
Contenido 4.6.24 mit PHP 5.6.40 und 5.5.5-10.1.47-MariaDB
Contenido 4.8.20 mit PHP 5.6.40 und 5.7.35-1 MySQL
Contenido 4.10.1-dev mit PHP 8.0.16 und 10.4.21-MariaDB

Laufen alle problemlos.
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

bodil
Beiträge: 274
Registriert: Fr 7. Okt 2011, 04:10
Kontaktdaten:

Re: Übersicht Minimal- und Maximalanforderungen verschiedener Contenido Versionen

Beitrag von bodil » Sa 11. Jun 2022, 16:37

Heidiho!

Ich finde folgende (problemlose) Kombinationen, die Angaben habe ich so übernommen, wie sie in den Systemeinstellungen stehen:

4.10.1:
PHP 7.3.33, 5.5.68-MariaDB
PHP 7.4.29, 5.7.38-log
PHP 7.4.28, 5.7.33
PHP 7.1.32, 5.6.19-67.0-log
PHP 7.4.28, 5.5.5-10.5.15-MariaDB
PHP 7.3.30, 5.1.73-14.12
PHP 7.2.34, 5.7.38-0ubuntu

4.10.0
PHP 7.3.33-nmm1, 5.5.5-10.5.15-MariaDB
PHP 7.4.28, 5.7.25

4.9.12
PHP 7.4.28, 5.7.25
PHP 5.6.40, 5.1.73-14.12

Antworten