tinymce löscht object Tag

Gesperrt
stefkey
Beiträge: 556
Registriert: Mi 19. Okt 2005, 16:10
Wohnort: Heidelberg
Kontaktdaten:

tinymce löscht object Tag

Beitrag von stefkey » Di 15. Jul 2008, 11:50

Hallo,

der tinymce macht mir aus:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shoc ... n=6,0,40,0" width="200" height="150">
<param name="src" value="upload/flash/tralala.swf" />
<param name="width" value="200" />
<param name="height" value="150" />
<embed type="application/x-shockwave-flash" src="upload/flash/tralala.swf" width="200" height="150"></embed>
</object>


immer:

<img src="contenido/external/wysiwyg/tinymce2/jscripts/tiny_mce/themes/advanced/images/spacer.gif" border="0" title="width:'200',height:'150',src:'upload/flash/tralala.swf'" width="200" height="150">


Ich habe auch in den Mandanteneinstellungen folgendes eingetragen:

tinymce valid_elements *[*]
tinymce extended_valid_elements *[*]


Was muss ich tun damit der tinymce einfach alles so lässt?


Grüße,
stefkey

emergence
Beiträge: 10599
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Beitrag von emergence » Di 15. Jul 2008, 13:53

ich glaub im tinymce3 geht das...
*** make your own tools (wishlist :: thx)

stefkey
Beiträge: 556
Registriert: Mi 19. Okt 2005, 16:10
Wohnort: Heidelberg
Kontaktdaten:

Beitrag von stefkey » Di 15. Jul 2008, 14:18

aber in der 4.6.23 ging das schon!

Außerdem bleibt auch nur

<img src="contenido/external/wysiwyg/tinymce2/jscripts/tiny_mce/themes/advanced/images/spacer.gif" border="0" title="width:'200',height:'150',src:'upload/flash/tralala.swf'" width="200" height="150">

übrig wenn ich mit "Flash einfügen" oder "eingebettete Medien einfügen" im tinymce arbeite.



Seit dem Update auf 4.8.6 gibts Probleme!


Gibts irgendwelche Tricks?

Grüße,
stefkey

stefkey
Beiträge: 556
Registriert: Mi 19. Okt 2005, 16:10
Wohnort: Heidelberg
Kontaktdaten:

Beitrag von stefkey » Di 15. Jul 2008, 14:59

Wenn ich in den Mandanteneinstellungen
xhtml true statt false eintrage funktioniert es

Aber das ist doch kein xhtml?!?!


was ist da falsch?



Danke und Grüße
stefkey

emergence
Beiträge: 10599
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Beitrag von emergence » Di 15. Jul 2008, 16:39

das kann ich dir nur ungefähr sagen...

tinymce interna...
ein bug der zwar gemeldet wurde, aber erst in der 3.x version behoben wurde... bzw nicht mehr auftrat...
*** make your own tools (wishlist :: thx)

homtata
Beiträge: 977
Registriert: Mi 14. Jan 2004, 14:41
Kontaktdaten:

Re: tinymce löscht object Tag

Beitrag von homtata » Mo 13. Jul 2009, 10:28

... und um dem ganzen die Krone aufzusetzen und das Ärgernis mit dem wirklich nicht besonders gut mit Contenido zusammenarbeitenden TinyMCE3 noch zu erweitern:

Der mit der Versin 4.8.12 mitgelieferte TinyMCE3 verweigert das Einbauen von Mediendateien (in meinem Fall: Flash). Das Eingabefenster wird einfach wieder geleert, eine Flashdatei nie eingebaut, der Quellcode nichtmal verändert.
Lade ich hingegen den Unterordner aus der 4.8.11 des TinyMCE in die 4.8.12, ist das Einbauen von Mediendateien im Fließtext wieder möglich...

Wir müssten wirklich mal einen Sammelthread zum Umgang mit TinyMCE3 machen, den das bringt im Moment sowohl die Redakteure als auch mich als Admin an die Grenze.

Gesperrt