[#22] Installation 4.10.1 geht nicht Database failure: 1067

Alle bestätigten Fehler in CONTENIDO 4.10 (erledigte Fehler werden durch geschlossene Beiträge gekennzeichnet).
Antworten
sarronsarron
Beiträge: 247
Registriert: Do 10. Mär 2011, 17:02
Wohnort: Erlangen
Kontaktdaten:

[#22] Installation 4.10.1 geht nicht Database failure: 1067

Beitrag von sarronsarron » Do 14. Nov 2019, 15:44

Hallo,

wollte gerade die neue Version 4.10.1 auf meinem Rechner unter xampp 7.3.11 (PHP 7.3.11) installieren.

Im letzten Schritt bekomme ich den folgenden Hinweis:

Installationsergebnisse
Setup Fehler während der Installation. Bitte schauen Sie in die Datei setuplog.txt (befindet sich im Verzeichnis "data/logs/") für weitere Informationen.
Die Datei setuplog.txt kann ich aber in keinem Verzeichniss finden.

Hat jemand einen Tip?

Gruß sarron
Zuletzt geändert von sarronsarron am Do 14. Nov 2019, 16:29, insgesamt 1-mal geändert.

sarronsarron
Beiträge: 247
Registriert: Do 10. Mär 2011, 17:02
Wohnort: Erlangen
Kontaktdaten:

Re: Installation 4.10.1 geht nicht

Beitrag von sarronsarron » Do 14. Nov 2019, 16:07

In der errorlog.txt stehlt folgenden

[2019-11-14 16:05:36] Warning: "Database failure: 1067 (Invalid default value for 'logtimestamp') - /entwicklung/contenido4101/setup/index.php?c=db ALTER TABLE `con_actionlog` CHANGE COLUMN `idlog` `idlog` int(11) NOT NULL
" at reportHalt() [class.db.driver.handler.php(1013)]
reportHalt() called in file class.db.driver.handler.php(985)
halt() called in file class.db.driver.handler.php(705)
query() called in file functions.database.php(149)
dbUpgradeTable() called in file include.db.controller.php(51)
include() called in file index.php(47)

könnt ihr damit etwas anfangen?

Gruß sarron

xmurrix
Beiträge: 2982
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: Installation 4.10.1 geht nicht Database failure: 1067

Beitrag von xmurrix » Do 14. Nov 2019, 16:43

Hallo sarron,

das XAMPP Paket 7.3.11 enthält MariaDB 10.4.8 und diese Version hat strikte SQL Modes gesetzt.

In der ...\xampp\mysql\bin\my.ini steht folgendes drin:

Code: Alles auswählen

sql_mode=NO_ZERO_IN_DATE,NO_ZERO_DATE,NO_ENGINE_SUBSTITUTION
Wenn du den SQL Server stoppst und es wie folgt änderst

Code: Alles auswählen

sql_mode=
sollte dann das Setup sauber durchlaufen.

Zur fehlenden "setuplog.txt":
Es kann sein, dass nicht alle Fehler beim Setup in der setuplog.txt landen, anscheinend wird auch was in die errorlog.txt geschrieben.


Nachtrag:
Die SQL modes "NO_ZERO_IN_DATE,NO_ZERO_DATE" erlauben nicht Datumswerte mit nullen, z. B. "0000-00-00", der SQL Mode "NO_ENGINE_SUBSTITUTION" macht auch beim Setup Probleme, daher sollte dieser auch nicht in der my.ini gesetzt werden. Ich habe den SQL Mode in der my.ini auf einen leeren Wert gesetzt:

Code: Alles auswählen

sql_mode=
Damit ist das Setup unter XAMPP 7.3.11 durchgelaufen, es gab weder einen Eintrag in der errorlog.txt, noch in der setuplog.txt.

Gruß
xmurrix
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

Oldperl
Beiträge: 4160
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Re: Installation 4.10.1 geht nicht Database failure: 1067

Beitrag von Oldperl » Do 14. Nov 2019, 16:43

Servus,

ja, ein Bug. Siehe :arrow: viewtopic.php?f=118&t=43768

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

sarronsarron
Beiträge: 247
Registriert: Do 10. Mär 2011, 17:02
Wohnort: Erlangen
Kontaktdaten:

Re: Installation 4.10.1 geht nicht Database failure: 1067

Beitrag von sarronsarron » Do 14. Nov 2019, 16:54

SUUUUUUUPER!!!!

habs so geändert und hat sofort funktioniert. Klasse!!

Gruß sarron

sarronsarron
Beiträge: 247
Registriert: Do 10. Mär 2011, 17:02
Wohnort: Erlangen
Kontaktdaten:

Re: Installation 4.10.1 geht nicht Database failure: 1067

Beitrag von sarronsarron » Do 14. Nov 2019, 17:58

Hallo,

jetzt hat auch am Echtserver alles funktioniert. Einiges ist mir aber noch aufgefallen.

1.) Unter Administration/Mandanten/CONTENIDO Demo wird der Server-Pfad und die Web-Adresse nicht richtig eingetragen. Es standen immer noch die Werte der Testversion drinnen.

2.) Während der Installation wir gemeckert, dass bestimmte Bereiche nicht beschreibbar sind. Wenn ich diese Verzeichnisse schreibbar mache wird das von der Fehlermeldung ignoriert. Die Fehlermeldung erscheint immer wieder. Ich habe dann mit der Installation weitergemacht und es hat trotzdem funktioniert.

Gruß sarron

xmurrix
Beiträge: 2982
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: Installation 4.10.1 geht nicht Database failure: 1067

Beitrag von xmurrix » Mi 20. Nov 2019, 14:21

Danke für das Feedback, es wurde ein Ticket dafür erstellt:
https://github.com/CONTENIDO/CONTENIDO/issues/22

Grüße
xmurrix
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

Antworten