[#16] Fehler bei Upgrade von 4.9.12 auf 4.10.1

Alle bestätigten Fehler in CONTENIDO 4.10 (erledigte Fehler werden durch geschlossene Beiträge gekennzeichnet).
Antworten
ncf
Beiträge: 17
Registriert: Di 15. Aug 2006, 07:57
Wohnort: Magdeburg
Kontaktdaten:

[#16] Fehler bei Upgrade von 4.9.12 auf 4.10.1

Beitrag von ncf » Di 12. Nov 2019, 13:55

Hallo zusammen,

ich bin heute mit meinem ersten Server auf 4.10.1 umgestiegen, um auch mit PHP7 Contenido nutzen zu können. Dabei sind mir im Upgradeprozess ein paar Probleme aufgefallen, die ich lokal korrigiert habe, die aber mglw. auch anderen auf die Füße fallen.

Zuerst meine Parameter:
- Webserver-Version Apache/2.4.25 (Debian)
- Installierte PHP-Version 7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82
- Datenbankserver-Version 5.5.5-10.1.26-MariaDB-0+deb9u1
- PHP-Datenbankerweiterung mysqli

Dabei gab es diverse SQl-Fehler, die fast komplett aufgrund Verwendung von doppelten Anführungszeichen im SQL-Statement auftraten. Für mich habe ich das korrigiert, damit lief das Update, aber vielleicht sollte man hier auch im Original mal anpassen?

Datei: /contenido/classes/class.systemtest.php, Zeile 1467

Code: Alles auswählen

$db->query('SHOW TABLES LIKE "%s_actions"', $databasePrefix);
ersetzt durch

Code: Alles auswählen

$db->query('SHOW TABLES LIKE \'%s_actions\'', $databasePrefix);
Datei: /contenido/classes/class.systemtest.php, Zeile 1475

Code: Alles auswählen

$db->query('SHOW TABLES LIKE "%s_test"', $databasePrefix);
ersetzt durch

Code: Alles auswählen

$db->query('SHOW TABLES LIKE \'%s_test\'', $databasePrefix);
Datei: /contenido/classes/class.systemtest.php, Zeile 1529

Code: Alles auswählen

$sql = 'SHOW TABLES LIKE "%s_actions"';
ersetzt durch

Code: Alles auswählen

$sql = 'SHOW TABLES LIKE \'%s_actions\'';
Datei: /setup/upgrade_jobs/class.upgrade.job.main.php, Zeile 117

Code: Alles auswählen

$this->_oDb->query('SHOW TABLES LIKE "%s"', $cfg['sql']['sqlprefix'] . '_phplib_auth_user_md5');
ersetzt durch

Code: Alles auswählen

$this->_oDb->query('SHOW TABLES LIKE \'%s\'', $cfg['sql']['sqlprefix'] . '_phplib_auth_user_md5');
Datei: /setup/upgrade_jobs/class.upgrade.job.main.php, Zeile 120

Code: Alles auswählen

$this->_oDb->query('SHOW TABLES LIKE "%s"', $cfg['sql']['sqlprefix'] . '_user');
ersetzt durch

Code: Alles auswählen

$this->_oDb->query('SHOW TABLES LIKE \'%s\'', $cfg['sql']['sqlprefix'] . '_user');
Datei: /setup/lib/functions.sql.php, Zeile 171

Code: Alles auswählen

$db->query('SHOW TABLES LIKE "%s"', $table);
ersetzt durch

Code: Alles auswählen

$db->query('SHOW TABLES LIKE \'%s\'', $table);
Datei: /setup/lib/functions.sql.php, Zeile 205

Code: Alles auswählen

$db->query('SHOW TABLES LIKE "%s"', $cfg["sql"]["sqlprefix"] . "_piwf_art_allocation");
ersetzt durch

Code: Alles auswählen

$db->query('SHOW TABLES LIKE \'%s\'', $cfg["sql"]["sqlprefix"] . "_piwf_art_allocation");
Datei: /setup/data/base/base_misc1.sql

Code: Alles auswählen

UPDATE !PREFIX!_art_lang SET published=lastmodified, publishedby=modifiedby WHERE online=1 and published="0000-00-00 00:00:00";
ersetzt durch

Code: Alles auswählen

UPDATE !PREFIX!_art_lang SET published=lastmodified, publishedby=modifiedby WHERE online=1 and published='0000-00-00 00:00:00';

Danach ist das Update sauber durchgelaufen und bisher scheint Contenido super zu funktionieren. Vielen Dank an die Unermüdlichen, die das Projekt am Laufen halten.

xmurrix
Beiträge: 2982
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: Fehler bei Upgrade von 4.9.12 auf 4.10.1

Beitrag von xmurrix » Di 12. Nov 2019, 23:58

Hallo ncf,

die Fehler kamen bei dir sehr wahrscheinlich wegen einer Einstellung des Datenbankservers.

Ich weiß jetzt auf Anhieb nicht, ob das die default-Einstellung ist, aktiviert man aber den SQL Mode "ANSI_QUOTES", so werden " (doppeltes Hochkomma) nicht als ` (backtick) interpretiert.

Siehe:
https://dev.mysql.com/doc/refman/5.5/en ... nsi_quotes

Am Besten ist es, wenn man den SQL Mode auf "MYSQL40" einstellt, damit sollte CONTENIDO ohne Probleme funktionieren.

Danke auf jeden Fall für das Feedback.

Gruß
xmurrix
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

xmurrix
Beiträge: 2982
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: [#16] Fehler bei Upgrade von 4.9.12 auf 4.10.1

Beitrag von xmurrix » Mi 13. Nov 2019, 12:44

Für das Problem wurde ein Ticket angelegt:
https://github.com/CONTENIDO/CONTENIDO/pull/16

Nochmals danke!
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

Antworten