SSL-Verschlüsselung - FAQ hilft nicht

Alles rund um Module und Plugins in CONTENIDO 4.10.
Antworten
Ina S
Beiträge: 1
Registriert: Di 5. Jan 2021, 11:20
Kontaktdaten:

SSL-Verschlüsselung - FAQ hilft nicht

Beitrag von Ina S » Di 5. Jan 2021, 11:25

Hallo,
möchte meine Seite "sicher" machen. In den FAQs steht unter "Ist es möglich Contenido mit einer SSL-Verschlüsselung zu betreiben?" etwas von der Konfigurationsdatei "config.php" im Ordner "data/config". Ich finde diese Datei einfach nicht. Zertifikat habe ich schon besorgt. Vielen Dank im Voraus für eine kompetente Antwort. LG

xmurrix
Beiträge: 2982
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: SSL-Verschlüsselung - FAQ hilft nicht

Beitrag von xmurrix » Di 5. Jan 2021, 11:50

Hallo Ina S,

herzlich willkommen im CONTENIDO-Forum.

Die Datei „config.php“ wird im Ordner „data/config/{umgebungsname}/“ während des Setups, also während der Installation von CONTENIDO, generiert. Falls CONTENIDO nicht installiert wurde, gibt es die Datei auch nicht.

Ab CONTENIDO 4.9 findest du die Konfigurationsdateien unter „data/config/{umgebungsname}/“ und bis CONTENIDO 4.8 waren die unter „contenido/includes“ drin.

Falls es sich bei dir um eine Umstellung auf SSL bei einer schon vorhandenen Seite handelt, musst du bei CONTENIDO >= 4.9 folgende Anpassungen/Änderungen machen:
1. Ändern der Pfade von http://... In https://... in der Datei data/config/{umgebungsname}/config.php
2. Ändern der Pfade von http://... In https://... in der Datei data/config/{umgebungsname}/config.clients.php
3. Sofern vorhanden, ändern der Pfade von http://... In https://... in Layouts
4. Sofern vorhanden, ändern der Pfade von http://... In https://... in Modulausgaben
5. Sofern vorhanden, ändern der Pfade von http://... In https://... in Weiterleitungen (in Artikeln) und anderen Inhaltselementen (z. B. Text)
6. Sofern vorhanden, ändern der Pfade von http://... In https://... in einer vorhandenen .htaccess Datei

Die Punkte 1 – 2 sind das Mindeste, was man machen muss.
Hat man in Layouts und Modulausgaben (Punkt 3 und 4) nicht mit der vorhandenen Konfiguration gearbeitet oder absolute Pfade mit http://... verwendet, so sind die auch anzupassen. Das gilt auch für Punkt 5 und 6.

Zum Schluss sollte man den Cache leeren, damit der Code für die Seiten neu generiert wird. Das geht im Backend unter „Administration > System > Bereinigung“. Dort den Mandaten auswählen, die Option „Code-Cache löschen“ anwählen und mit Klick auf den grünen Button, das Löschen des Caches bestätigen.

Grüße
xmurrix
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

q166132
Beiträge: 1
Registriert: Di 18. Mai 2021, 09:20
Kontaktdaten:

Re: SSL-Verschlüsselung - FAQ hilft nicht

Beitrag von q166132 » Di 18. Mai 2021, 09:39

Hallo xmurrix,

wir nutzen die Version 4.8.18.
Ich habe auch in der contenido/includes/config.php diese Zeile angepasst:
$cfg['path']['contenido_fullhtml'] = 'https://www.xxx.de/contenido/';

Weitere http-Anfänge habe ich in dieser Datei nicht gefunden.

Jetzt werden aber 2 Stylesheets, 2 Scripte und das Favicon blockiert.
CSS liegen unter http://www.xxx.de/cms/css/style.css
JS liegen unter http://www.xxx.de/cms/js/xxx.js
Favicon liegt unter http://www.xxx.de/cms/favicon.ico

In welcher Datei muss ich https noch ändern?

Danke Dir
Mike

xmurrix
Beiträge: 2982
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: SSL-Verschlüsselung - FAQ hilft nicht

Beitrag von xmurrix » Di 18. Mai 2021, 10:17

Hallo Mike,

willkommen im CONTENIDO Forum.

In CONTENIDO 4.8 werden Pfade noch teilweise in der Datenbank gepflegt. Du musst also in der Tabelle "con_clients" den Eintrag anpassen.

Danach solltest du die Tabellen "con_code" und "con_phplib_active_sessions" leeren, damit der Code der Seiten neu generiert wird und die Session der aktuell aktiven Benutzer neu gesetzt wird, der HTML-Pfad des Mandanten wird in CONTENIDO 4.8 auch in der Session abgelegt.

Oft kommt es vor, dass noch Pfade in Artikeleigenschaften (Weiterleitung), Layouts, Templates Modulen oder in redaktionellen Inhalten (WYSIWYG-Text) vorkommt, die Bereiche solltest du dir auch ansehen.

Gruß
xmurrix
CONTENIDO downloads: CONTENIDO 4.10.1
CONTENIDO links: Documentation, API documentation
CONTENIDO @ Github: CONTENIDO 4.10

bodil
Beiträge: 232
Registriert: Fr 7. Okt 2011, 04:10
Kontaktdaten:

Re: SSL-Verschlüsselung - FAQ hilft nicht

Beitrag von bodil » Di 18. Mai 2021, 12:33

Hallo zusammen!
Eine weitere Anpassung ist sinnvoll. In der Datei data/config/(...)/config.misc.php ist der Wert $cfg['secure'] definiert. Der sollte, wenn die Seite mit https läuft, auf true gesetzt sein (Default: false). Da geht es darum, dass der von Contenido verwendete Cookie zur verschlüsselten Webseite passt.
Viel Erfolg!
Bodil

Faar
Beiträge: 1720
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: SSL-Verschlüsselung - FAQ hilft nicht

Beitrag von Faar » Mi 19. Mai 2021, 12:45

bodil hat geschrieben:
Di 18. Mai 2021, 12:33
Hallo zusammen!
Eine weitere Anpassung ist sinnvoll. In der Datei data/config/(...)/config.misc.php ist der Wert $cfg['secure'] definiert. Der sollte, wenn die Seite mit https läuft, auf true gesetzt sein (Default: false). Da geht es darum, dass der von Contenido verwendete Cookie zur verschlüsselten Webseite passt.
Viel Erfolg!
Bodil
Danke, das könnte das https-Problem bei einer alten 4.8 Seite erklären, weshalb der Browser dort noch einen Fehler anzeigt, obwohl alle Adressen mit https umgeschrieben sind.
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

Antworten