Nach Server wechsel

Fragen zur Installation von CONTENIDO 4.10? Probleme bei der Konfiguration? Hinweise oder Fragen zur Entwicklung des Systemes oder zur Sicherheit?
Antworten
Peer
Beiträge: 290
Registriert: Fr 9. Sep 2005, 17:22
Kontaktdaten:

Nach Server wechsel

Beitrag von Peer » Sa 2. Nov 2019, 18:06

Moin,

bin mit einem Projekt Contenido 4.10 von einem Server zum anderen Server umgezogen.
Hat nicht so super geklappt.

Einige Einstellungen musste ich per Hand noch mal anpassen.

An einer Stelle finde ich aber nicht direkt die Lösung.
Im Backend reagieren die Links für Conten, Style ... nicht.

Vor dem Server wechsel kein Problem.

Hat jemand eine Idee bzw. vielleicht sogar eine Lösung?

Vielen Dank

Gruß

Peer

homtata
Beiträge: 1064
Registriert: Mi 14. Jan 2004, 14:41
Kontaktdaten:

Re: Nach Server wechsel

Beitrag von homtata » So 3. Nov 2019, 00:25

Es sind fast immer die Klassiker:
- es sind doch nicht alle Dateien umgezogen, irgendwas fehlt. Contenido-Ordner nochmal hochladen
- die config-Dateien wurden nicht korrekt angepasst, die Pfade stimmen nicht zu 100% auf den neuen Server config.php/config.clients.php
- das setup wurde sicherheitshalber nicht noch mal drübergebügelt
- die cache-Dateien wurden über System/Bereinigung nicht geleert

mattmarr
Beiträge: 340
Registriert: Mo 3. Aug 2009, 14:11
Kontaktdaten:

Re: Nach Server wechsel

Beitrag von mattmarr » So 3. Nov 2019, 11:49

Hallo Peer,

meistens sind irgendwelche Pfade nicht korrekt.

Ich gehe bei einem Umzug immer folgendermaßen vor und habe bisher nie Probleme gehabt:
  • Im der Datei ./data/config/.../config.php Pfade für $cfg['path']['frontend'] und $cfg['path']['contenido_fullhtml'] anpassen.
  • Im der Datei ./data/config/.../config.php Datenbankeinträge anpassen
  • Contenido Backend aufrufen und einloggen
  • Im Contenido dann unter Mandanten die Pfade an die neue Situation anpassen
  • Im Contenido Administration > System > Bereinigung alle Caches Leeren lassen
  • erst Jetzt die Frontent-Seite aufrufen
  • Sollten jetzt noch Probleme auftreten die Logs unter ./data/logs prüfen
Hoffe ich konnte etwas helfen.


Gruß
Matthias

Peer
Beiträge: 290
Registriert: Fr 9. Sep 2005, 17:22
Kontaktdaten:

Re: Nach Server wechsel

Beitrag von Peer » So 3. Nov 2019, 14:11

Moin Leute,

danke für eure Beiträge.
Habe jetzt ein Update auf 4.10.1.

Läuft jetzt - Danke

mattmarr
Beiträge: 340
Registriert: Mo 3. Aug 2009, 14:11
Kontaktdaten:

Re: Nach Server wechsel

Beitrag von mattmarr » So 3. Nov 2019, 16:17

Hallo Perr,

kannst Du vielleicht noch mitteilen was das Problem war?


Gruß
Matthias

Antworten