Contenido Crash?

Gesperrt
Bruder Barnabas
Beiträge: 5
Registriert: Mi 24. Dez 2003, 22:11
Kontaktdaten:

Contenido Crash?

Beitrag von Bruder Barnabas » Do 25. Dez 2003, 12:46

Hi Leute,
ich habe ein Problem - und zwar kann ich die artikel nicht mehr bearbeiten.
wenn ich auf eine Kategorie klicke, dann komme ich in die Übersicht aber wenn ich dann in den Editor ect.. will geht das nicht. Er lädt das einfach nicht.

Ich habe gestern nur mit dem Guestbook rumprobiert. Habe sonst nix im Style oder so geändert. Nur im Guestbook modul!
Kann das daher kommen? Ich habe aber das Modul gelöscht und es geht immer noch nicht.

Habt ihr ne Ahnung was ich falsch gemacht habe oder was ich ausprobieren könnte, damit es wieder geht?

Wär richtig klasse!

Ciao
Frohe Weihnachten!!!!

Bruder Barnabas

emergence
Beiträge: 10603
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Beitrag von emergence » Di 30. Dez 2003, 15:18

was steht im errorlog.txt

Bruder Barnabas
Beiträge: 5
Registriert: Mi 24. Dez 2003, 22:11
Kontaktdaten:

Beitrag von Bruder Barnabas » Di 30. Dez 2003, 20:31

Der Errorlog
[27-Dec-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/conlib/session.inc on line 467
[27-Dec-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/conlib/session.inc on line 468
[27-Dec-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/conlib/session.inc on line 469
[27-Dec-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/conlib/session.inc on line 470
[27-Dec-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/conlib/session.inc on line 471
[27-Dec-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/conlib/session.inc on line 472
[27-Dez-2003 17:45:51] PHP Warning: Cannot modify header information - headers already sent by (output started at

/home/www/web1042/html/contenido/contenido/includes/cfg_sql.inc.php:73) in /home/www/web1042/html/contenido/contenido/logout.php on line 51
Die cfg_sql.inc.php
<?php

/******************************************
* File : cfg_sql.inc.php
* Project : Contenido
* Descr : Definition of SQL-Vars
*
* Author : Jan Lengowski
* Created : 21.01.2003
* Modified : 21.01.2003
*
* © four for business AG
******************************************/

global $cfg;

$cfg["tab"]["art"] = $cfg['sql']['sqlprefix']."_art";
$cfg["tab"]["art_lang"] = $cfg['sql']['sqlprefix']."_art_lang";
$cfg["tab"]["cat"] = $cfg['sql']['sqlprefix']."_cat";
$cfg["tab"]["cat_art"] = $cfg['sql']['sqlprefix']."_cat_art";
$cfg["tab"]["cat_tree"] = $cfg['sql']['sqlprefix']."_cat_tree";
$cfg["tab"]["cat_lang"] = $cfg['sql']['sqlprefix']."_cat_lang";
$cfg["tab"]["clients"] = $cfg['sql']['sqlprefix']."_clients";
$cfg["tab"]["clients_lang"] = $cfg['sql']['sqlprefix']."_clients_lang";
$cfg["tab"]["code"] = $cfg['sql']['sqlprefix']."_code";
$cfg["tab"]["content"] = $cfg['sql']['sqlprefix']."_content";
$cfg["tab"]["lang"] = $cfg['sql']['sqlprefix']."_lang";
$cfg["tab"]["lay"] = $cfg['sql']['sqlprefix']."_lay";
$cfg["tab"]["mod"] = $cfg['sql']['sqlprefix']."_mod";
$cfg["tab"]["news"] = $cfg['sql']['sqlprefix']."_news";
$cfg["tab"]["news_rcp"] = $cfg['sql']['sqlprefix']."_news_rcp";
$cfg["tab"]["stat"] = $cfg['sql']['sqlprefix']."_stat";
$cfg["tab"]["stat_archive"] = $cfg['sql']['sqlprefix']."_stat_archive";
$cfg["tab"]["status"] = $cfg['sql']['sqlprefix']."_status";
$cfg["tab"]["tpl"] = $cfg['sql']['sqlprefix']."_template";
$cfg["tab"]["tpl_conf"] = $cfg['sql']['sqlprefix']."_template_conf";
$cfg["tab"]["type"] = $cfg['sql']['sqlprefix']."_type";
$cfg["tab"]["upl"] = $cfg['sql']['sqlprefix']."_upl";
$cfg["tab"]["keywords"] = $cfg['sql']['sqlprefix']."_keywords";
$cfg["tab"]["area"] = $cfg['sql']['sqlprefix']."_area";
$cfg["tab"]["actions"] = $cfg['sql']['sqlprefix']."_actions";
$cfg["tab"]["nav_main"] = $cfg['sql']['sqlprefix']."_nav_main";
$cfg["tab"]["nav_sub"] = $cfg['sql']['sqlprefix']."_nav_sub";
$cfg["tab"]["rights"] = $cfg['sql']['sqlprefix']."_rights";
$cfg["tab"]["container"] = $cfg['sql']['sqlprefix']."_container";
$cfg["tab"]["container_conf"] = $cfg['sql']['sqlprefix']."_container_conf";
$cfg["tab"]["files"] = $cfg['sql']['sqlprefix']."_files";
$cfg["tab"]["framefiles"] = $cfg['sql']['sqlprefix']."_frame_files";
$cfg["tab"]["plugins"] = $cfg['sql']['sqlprefix']."_plugins";
$cfg["tab"]["phplib_active_sessions"] = $cfg['sql']['sqlprefix']."_phplib_active_sessions";
$cfg["tab"]["phplib_auth_user_md5"] = $cfg['sql']['sqlprefix']."_phplib_auth_user_md5";
$cfg["tab"]["actionlog"] = $cfg['sql']['sqlprefix']."_actionlog";
$cfg["tab"]["link"] = $cfg['sql']['sqlprefix']."_link";
$cfg["tab"]["meta_type"] = $cfg['sql']['sqlprefix']."_meta_type";
$cfg["tab"]["meta_tag"] = $cfg['sql']['sqlprefix']."_meta_tag";
$cfg["tab"]["groups"] = $cfg['sql']['sqlprefix']."_groups";
$cfg["tab"]["group_prop"] = $cfg['sql']['sqlprefix']."_group_prop";
$cfg["tab"]["groupmembers"] = $cfg['sql']['sqlprefix']."_groupmembers";
$cfg["tab"]["config"] = $cfg['sql']['sqlprefix']."_config";
$cfg["tab"]["config_client"] = $cfg['sql']['sqlprefix']."_config_client";
$cfg["tab"]["data"] = $cfg['sql']['sqlprefix']."_data";
$cfg["tab"]["lang_bereich"] = $cfg['sql']['sqlprefix']."_lang_bereich";
$cfg["tab"]["lang_key"] = $cfg['sql']['sqlprefix']."_lang_key";
$cfg["tab"]["lang_value"] = $cfg['sql']['sqlprefix']."_lang_value";
$cfg["tab"]["sequence"] = $cfg['sql']['sqlprefix']."_sequence";
$cfg["tab"]["sessions"] = $cfg['sql']['sqlprefix']."_sessions";
$cfg["tab"]["user_prop"] = $cfg['sql']['sqlprefix']."_user_prop";
$cfg["tab"]["inuse"] = $cfg['sql']['sqlprefix']."_inuse";
$cfg["tab"]["sessions"] = $cfg['sql']['sqlprefix']."_sessions";
$cfg["tab"]["user_prop"] = $cfg['sql']['sqlprefix']."_user_prop";


?>
Was ist denn da falsch in Zeile 73 ??? ( zeile 73 ist die letzte Zeile in der "?>" steht !!)

Ich hatte wegen dem Gästebuch was in die cfg_sql.inc.php reinkopiert.
und wieder rausgenommen...da muss mir der fehler passiert sein, aber ich weis jetzt nicht mehr wie es ursprünglich ausgesehen hat.

Danke für die hilfe!

Ciao
Sebastian

emergence
Beiträge: 10603
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Beitrag von emergence » Di 30. Dez 2003, 20:44

die fehlermeldung rührt daher das am ende deiner datei bei
(zeile 73 ist die letzte Zeile in der "?>" steht !!) am ende nach dem ?> entweder ein leerzeichen oder ein paar enter vorhanden sind...

d.h nach ?>| muss schluss sein, bei
?> | oder
?>
|

gibts sicher 'ne fehlermeldung
das | steht für das ende der datei...

das ist vermutlich falsch ;-)

Bruder Barnabas
Beiträge: 5
Registriert: Mi 24. Dez 2003, 22:11
Kontaktdaten:

Beitrag von Bruder Barnabas » Di 30. Dez 2003, 20:52

Danke emergence!

Das war's!
nach dem ?> war noch 1 Leerzeichen!

Da wär ich allein NIEMALS draufgekommen ;)

Cya

Sebastian

emergence
Beiträge: 10603
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Beitrag von emergence » Di 30. Dez 2003, 20:55

doch spätestens wenn du im netz nach "headers already sent by" gesucht hättest...
heisser tipp www.php.net

Arno Simon
Beiträge: 158
Registriert: Di 2. Sep 2003, 18:10
Kontaktdaten:

Beitrag von Arno Simon » Mo 5. Jan 2004, 05:25

Hi,

ich stehe vor einem ähnlichen (dem gleichen?!? - wohl eher nicht!) Problem :( :(

Bei mir wird seit neuestem - probiere es im neuen Jahr das erste mal - der FrontEnd nicht mehr geladen. D. h. es werden nur noch weiße Seiten angezeigt, wo vorher alles funktionierte.

Der Backend wird zwar angezeigt, jedoch ist ebenfalls keinerlei Anzeige bzw. Veränderung der Artikel etc. mehr möglich. Sobald aus der Artikelübersicht heraus ein Artikel aufgerufen wird, erscheint im entsprechenden Backend-Frame schlicht und ergreifend ..... nischt :(

Stehe im Moment vor einem Rätsel, da einfach nichts greift... auch das Deaktivieren der kompletten Module im Template greift nicht. Selbst in meinem Baustellen-Template (habe ich seit über einem Monat nicht mehr verändert), welches lediglich ein - ebenfalls seit längerem nicht geändertes - Link-Modul enthält funktioniert nicht mehr.

Lasse ich mir vom IE den Quelltext der aufgerufenen Seite anzeigen, wird kein Contenido-Output angezeigt, sondern lediglich der IE-Standard für eine Seite ohne Response die jedoch erreichbar ist und sonst keine Meldung (E403 / E404 oder sonstiges) auslöst. Sprich ein leerer HTML-Rumpf.

Die Kontrolle - und vorsorgliche Neuaufspielung - der oben erwähnten Datei brachte leider auch keine Besserung....

Hat jemand einen Tipp für mich, wo ich noch suchen kann?

Gruß

Arno

PS die ChMods der entsprechenden Verzeichnisse & Dateien habe ich natürlich auch - leider auch das Erfolglos - nochmals kontrolliert, da die Zeit zwischen dem 18. und 31. Dezember vom Provider auf neue Server umgezogen wurde.

PPS alle bislang Eingebauten Module zeigen im Editor auch nur Grün-Werte an. Dort liegt also scheinbar auch kein Fehler vor.....

emergence
Beiträge: 10603
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Beitrag von emergence » Mo 5. Jan 2004, 10:48

was steht im errorlog ?

ähm server umzug ?
sind die pfade in der contenido/includes/config.php korrekt ? ich denke nicht...
ebenfalls neu checken -> mandanten einstellungen im backend...

htw
Beiträge: 490
Registriert: Sa 5. Okt 2002, 03:09
Wohnort: Hessen
Kontaktdaten:

Crons und Statistik

Beitrag von htw » Mo 5. Jan 2004, 11:10

Hi,

wahrscheinlich liegt es nicht am neuen Jahr, sondern an einem neuen Monat. Wir wollen das neue Jahr erst mal wirken lassen ;-)

Die Statistik wird normalerweise zu Beginn eines neuen Monats geschrieben. Hast Du mal das Verzeichnis cronjobs geprüft, ob die richtigen Rechte vergeben sind? Das Frontend greift auf das Verzeichnis zu. Ansonsten kann ich nur emergence folgen und fragen was im errorlog steht.

Gruß
Harald

Karl
Beiträge: 185
Registriert: Fr 28. Nov 2003, 19:07
Kontaktdaten:

Beitrag von Karl » Mo 5. Jan 2004, 13:35

... mit "wirken lassen" meinst Du den Restalkohöl von Sylvester?
Irgendwie passt die Antwort hier nicht (gehört wohl eher in den Statistik Thread, oder?

Prost ...
Gruss Karl

Arno Simon
Beiträge: 158
Registriert: Di 2. Sep 2003, 18:10
Kontaktdaten:

Beitrag von Arno Simon » Mo 5. Jan 2004, 20:19

Hi,

das Problem hat sich gerade geklärt.

Es lag ursächlich am Umzug auf den neuen Server, wobei hier aber die Verzeichnisstrukturen gleich geblieben wahren - dennoch Dank an emergence für den Tipp.

Beim Umzug wurden die Eigentümer aller Files der Site auf den Standard-Benutzer des Hosters umgezogen und - genialer Weise :( - die Flags aller Dateien auf 411 runtergezogen. Die Flags der Verzeichnisse blieben erhalten, was aber nicht viel nutzte, weil die Berechtigungsprüfung des Hosters wohl darauf abgestimmt ist den Dateiflags vorrang einzuräumen......

In der "errorlog.txt" stand demzufolge nichts neues drin, denn diese war ebensowenig beschreibbar, wie die .job-Dateien des CronJob-Emulators, welche letztlich den Fehler auslösten, denn dadurch das die Dateien nicht upgedatet werden konnten, weigerte sich Contenido die Daten neu aufzubereiten und stieg an entsprechender Stelle mit einem - allerdings nur versuchten - Eintrag im Errorlog aus.

Dahintergekommen bin ich leider erst, als ich die errorlog-Datei einmal komplett gelöscht habe und neu schreiben lies.....

Thx 4 help, aber mir bleibt wohl nischt anders übrig als die Verzeichnisse einmal neu zu uppen um wieder Eigentümer der Dateien zu werden und somit die Flags selbst einstellen zu können ohne jedesmal bei der Hotline anrufen zu müssen und denen zu sagen: Gebt mir mal Flag xyz für die und die Datei :( :(

Gruß

Arno

PS falls ich's bislang vergessen haben sollte: Allen ein frohes neues Jahr ;)

Gesperrt