Läuft Version 4.6.24 mit php 5.4 bzw. 5.5?

Gesperrt
joe_ma
Beiträge: 101
Registriert: Sa 2. Jun 2007, 07:55
Kontaktdaten:

Läuft Version 4.6.24 mit php 5.4 bzw. 5.5?

Beitrag von joe_ma » Mi 27. Nov 2013, 14:44

Hallo

Bei einem Kunden von mir läuft schon lange eine 4.6.24 Installation. Nun hat er von seinem Provider die Nachricht erhalten, dass ab 2014 nur noch Websites unterstützt werden, welche mit php 5.4 oder 5.5 laufen.

Ist das bei dieser Version der Fall?
Oder muss ich da was speziell anpassen?

Letzteres möchte ich eigentlich wenn immer es geht, vermeiden (never touch a running system).
Gruss

Jörg Matter

xmurrix
Beiträge: 2642
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: Läuft Version 4.6.24 mit php 5.4 bzw. 5.5?

Beitrag von xmurrix » Mi 27. Nov 2013, 15:09

Hallo joe_ma,

die 4.6.24 wird nicht unter PHP 5.4 oder 5.5 laufen und die 4.6 er Reihe wird auch nicht weiterentwickelt.

Kann dir nur empfehlen, ein Update auf die neueste 4.8 zu machen. Das ist viel einfacher als der Versuch die Version 4.6.24 unter neuer PHP Version zum Laufen zu bekommen. Du musst auch damit rechnen, dass neben PHP auch die MySQL-Datenbank aktualisiert wird, was auch unter 4.6 Schwierigkeiten bereiten kann...

Vor kurzem ist CONTENIDO 4.8.19 rausgekommen. Noch besser wäre die Version 4.9, aber da must du mit ein paar Anpassungen mehr rechnen!

Nach dem Update würde ich auch alte Modulcodes und/oder verwendete Plugins prüfen. Die werden beim Update nicht überschrieben oder aktualisiert, hier musst du den Code selber kompatibel zu PHP 5.4 oder 5.5 machen.

Gruß
xmurrix
CONTENIDO downloads: CONTENIDO 4.9.12
CONTENIDO links: Documentation, API documentation

joe_ma
Beiträge: 101
Registriert: Sa 2. Jun 2007, 07:55
Kontaktdaten:

Re: Läuft Version 4.6.24 mit php 5.4 bzw. 5.5?

Beitrag von joe_ma » Mi 27. Nov 2013, 15:19

Danke Murrix.

Dann werde ich mich halt mal an die Arbeit machen. :-(
Gruss

Jörg Matter

Gesperrt