Modul: FLV Media Player (XHTML valide)

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Fr 26. Aug 2011, 19:13

BIG-BEN hat geschrieben:ich hab die zeilen im modul output jetzt mal wie beschrieben ersetzt aber
der fehler bleibt dennoch bestehen =( hatte es nich ausprobiert, da ich dachte
es hilft nur bei mod_rewrite was ich ja nich nutze.

aber wie gesagt bringt auch nix =(
Genau, steht doch alles im ersten Post :D

Nee, Spass beiseite, ich hab nochmal deinen und meine Quelltext miteinander verglichen. Der einzige Unterschied war, dass bei dir keine Startlautstärke eingegeben war. Ich hab die bei mir mal gelöscht. Und siehe da, das Modul ging nicht mehr...

Also bis ich es zeitlich schaffe, eine neue Version online zu stellen, bitte in der Modulkonfiguration eine Startlautstärke angeben! Eine Zahl zwischen 1 und 100. Ich nehme immer den Standardwert von 90.

So müsste es dann funktionieren.
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Fr 26. Aug 2011, 19:15

@slag

wenn du die neue Version noch einsetzen möchtest, versuch doch auch einmal, ob es mit dem Troubleshoot und einer eingestellten Startlautstärke funktioniert.
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

BIG-BEN
Beiträge: 190
Registriert: Do 18. Okt 2007, 09:47
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von BIG-BEN » Fr 26. Aug 2011, 19:37

Nebel hat geschrieben:
Also bis ich es zeitlich schaffe, eine neue Version online zu stellen, bitte in der Modulkonfiguration eine Startlautstärke angeben! Eine Zahl zwischen 1 und 100. Ich nehme immer den Standardwert von 90.

So müsste es dann funktionieren.
GENIAL!! es geht :mrgreen: DANKE! du hast mein WE gerettet :lol:

BagHira
Beiträge: 486
Registriert: Do 23. Feb 2006, 19:42
Wohnort: Tirschenreuth / Oberpfalz / Bayern
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von BagHira » Fr 26. Aug 2011, 21:40

Servus nebel,
Nebel hat geschrieben:Der einzige Unterschied war, dass bei dir keine Startlautstärke eingegeben war. Ich hab die bei mir mal gelöscht. Und siehe da, das Modul ging nicht mehr...
Ich hatte heute Mittag kurz mit Opera (gar net so schlecht :-)) geschaut und der meldete an dieser Stelle einen JS-Error.
Gruß Holger

Träumer haben vielleicht keinen Plan, aber Realisten haben keine Vision.

Handgewickelte Glasperlen Facebook Google+

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Sa 27. Aug 2011, 11:47

BagHira hat geschrieben: und der meldete an dieser Stelle einen JS-Error.
Ja, der erscheint, wenn die Startlautstärke nicht angegeben ist.
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

slag
Beiträge: 5
Registriert: Di 23. Aug 2011, 09:24
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von slag » Fr 2. Sep 2011, 09:35

@Nebel

sorry war die woche im Aussendienst.

Super, nach dem einstellen einer Startlautstärke funktioniert es jetzt, danke.

Nur hab ich nun das Problem, das er nur noch den Film anzeigt und alles andere ausblendet :?

Hier mal der direktlink

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Sa 3. Sep 2011, 14:48

Hmm, das ist mal merkwürdig. Hast du mal versucht, mit den verschiedenen Variablen ein bisschen herumzuspielen? Vorallem die Playlistengröße und die Anzeigeposition dieser und die der Kontrollbar vielleicht mal variieren.

Ansonsten könnte es auch einen Konflikt mit anderen Javascripten auf der Seite sein.
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

alderim
Beiträge: 246
Registriert: Do 17. Nov 2005, 12:22
Wohnort: Nürnberg
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von alderim » Fr 15. Feb 2013, 14:18

Moinsn Zusammen,

1. Danke für das Player-Modul!

2. Hat jemand evtl. einen Tipp ob man die Menü / bzw. Share Funktion deaktivieren / entfernen kann?

Danke und Grüße!
A.
Gruß,
Alderim

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Fr 19. Apr 2013, 12:07

alderim hat geschrieben:Moinsn Zusammen,

1. Danke für das Player-Modul!

2. Hat jemand evtl. einen Tipp ob man die Menü / bzw. Share Funktion deaktivieren / entfernen kann?

Danke und Grüße!
A.
Moin,

gerad erst die Lösung gefunden: man brauch dafür eine Player-Version ohne das sog. "viral plugin".
Unter http://developer.longtailvideo.com/trac ... player.swf die player.swf herunterladen und mit der vorhandenen austauschen bzw. umbenennen und in der Modul-Config unter "Player wählen:" die Datei auswählen.

*Edit*
Beim Klick auf die URL erscheint eine Forbidden Meldung, daher direkt in die Adressleiste eingeben:

Code: Alles auswählen

http://developer.longtailvideo.com/trac/browser/tags/mediaplayer-5.6/player.swf
und dann die Datei herunterladen.
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

Andreas
Beiträge: 254
Registriert: So 16. Nov 2003, 14:48
Wohnort: Reichshof
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Andreas » Mo 22. Apr 2013, 10:56

Hallo zusammen,

ich versuche das Modul zu nutzen.
Einbau und alles hat funktioniert. Pfade müßten auch stimmen.
Klicke ich jetzt jedoch auf den Play-Button, lädt sich zwar anscheinend die gewünschte MP3-Datei, aber sie wird nicht abgespielt...
Hat jemand eine Idee?
Hier die (noch versteckte) Seite: http://www.michaela2013.de/cms/front_co ... 7&idcat=11
Gruß
Andreas

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Mo 22. Apr 2013, 13:56

Andreas hat geschrieben:Hallo zusammen,

ich versuche das Modul zu nutzen.
Einbau und alles hat funktioniert. Pfade müßten auch stimmen.
Klicke ich jetzt jedoch auf den Play-Button, lädt sich zwar anscheinend die gewünschte MP3-Datei, aber sie wird nicht abgespielt...
Hat jemand eine Idee?
Hier die (noch versteckte) Seite: http://www.michaela2013.de/cms/front_co ... 7&idcat=11
Hi,

ich hab mal in deinen Quelltext geschaut. Irgendwie ist da was zuviel nach dem Beginn des Moduls in der Ausgabe

Code: Alles auswählen

<script type="text/javascript" src="js/jwplayer.js"></script>
<script type="text/javascript" src="js/swfobject.js"></script>
kommt bei dir

Code: Alles auswählen

<div style="position: relative;" id="container_wrapper"><object name="container" id="container" bgcolor="#000000" data="http://www.michaela2013.de/cms/upload/player/player.swf" type="application/x-shockwave-flash" height="24" width="575"><param value="true" name="allowfullscreen"><param value="always" name="allowscriptaccess"><param value="true" name="seamlesstabbing"><param value="opaque" name="wmode"><param value="netstreambasepath=http%3A%2F%2Fwww.michaela2013.de%2Fcms%2Ffront_content.php%3Fidart%3D147%26idcat%3D11&id=container&autostart=false&file=http%3A%2F%2Fwww.michaela2013.de%2Fcms%2Fupload%2Fmp3%2FFrauenquote.mp3&volume=90&image=http%3A%2F%2Fwww.michaela2013.de%2Fcms%2Fupload%2F00&logo=http%3A%2F%2Fwww.michaela2013.de%2Fcms%2Fupload%2F00&skin=http%3A%2F%2Fwww.michaela2013.de%2Fcms%2Fupload%2F00&backcolor=&frontcolor=&lightcolor=&screencolor=&bufferlength=&mute=false&repeat=none&stretching=fill&shuffle=false&controlbar.position=bottom&playlist.position=none&playlist.size=" name="flashvars"></object></div>
Das sollte da nicht stehen. Könnte das ein Überbleibsel eines anderen Moduls sein? Vielleicht mal in einem neu angelegten Artikel ausprobieren.
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

Andreas
Beiträge: 254
Registriert: So 16. Nov 2003, 14:48
Wohnort: Reichshof
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Andreas » Mo 22. Apr 2013, 14:24

Verstehe ich nicht.
Bei mir steht im Quelltext folgendes (auch nach Neuanlage des Artikels):

Code: Alles auswählen

	    <script type="text/javascript" src="js/jwplayer.js"></script>
<script type="text/javascript" src="js/swfobject.js"></script>
<div id="container">Der Player wird mit Javascript gestartet - bitte aktivieren.</div>
<script type="text/javascript">jwplayer("container").setup({
autostart: false,
controlbar: "bottom",
file: "http://www.michaela2013.de/cms/upload/mp3/Frauenquote.mp3",
flashplayer: "http://www.michaela2013.de/cms/upload/player/player.swf",
volume: 90,
width: 575,
height: 50,
image: "http://www.michaela2013.de/cms/upload/00",
logo: "http://www.michaela2013.de/cms/upload/00",
skin: "http://www.michaela2013.de/cms/upload/00",
backcolor: "",
frontcolor: "",
lightcolor: "",
screencolor: "",
playlist: "none",
playlistsize: "",
bufferlength: "",
mute: "false",
repeat: "none",
stretching: "fill",
shuffle: "false"}); </script>  
 
Gruß
Andreas

Nebel
Beiträge: 117
Registriert: Do 14. Jun 2007, 10:08
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Nebel » Mo 22. Apr 2013, 14:55

Stimmt, jetzt sieht er so aus. War eben irgendwie noch anders. Jetzt müsste eigentlich alles stimmen.

Hast du es mal mit einer anderen mp3-Datei probiert?
Schöne Grüße
Nebel

Module: FLV Media Player | DivX Webplayer | Quicktime Player

Andreas
Beiträge: 254
Registriert: So 16. Nov 2003, 14:48
Wohnort: Reichshof
Kontaktdaten:

Re: Modul: FLV Media Player (XHTML valide)

Beitrag von Andreas » Mo 22. Apr 2013, 16:05

Na klasse....
Die MP3-Datei war defekt.

Jetzt läuft es perfekt:
http://www.michaela2013.de/aktuelles/fr ... nk147.html

Vielen Dank für Deine Hilfe!!!
Gruß
Andreas

Gesperrt