Artikeltitel sind im Backend plötzlich z.T. verschwunden

Gesperrt
Parklife
Beiträge: 102
Registriert: Sa 19. Nov 2005, 20:28
Kontaktdaten:

Artikeltitel sind im Backend plötzlich z.T. verschwunden

Beitrag von Parklife » So 13. Mär 2016, 17:07

Ich habe seit einigen Tagen ein Problem mit Contenido 4.8.15 - wenn ich mich einlogge (als Sysadmin oder Redakteur, das ist egal) werden nur einige der Artikel mit Titel angezeigt - bei den anderen sehe ich ein leeres Feld, das ich logischerweise auch nicht anklicken kann, so dass keine Änderungen an dem Artikel mehr möglich sind. Im Frontend wird aber alles ganz normal, vollständig angezeigt, d.h. man merkt es als Websitebesucher nicht. Was kann hier das Problem sein? Bzw. was kann man tun, um das zu beheben?
Danke!
Dateianhänge
Bildschirmfoto-2016-03-13-um-17.02.04.png
(162.64 KiB) Noch nie heruntergeladen

homtata
Beiträge: 1109
Registriert: Mi 14. Jan 2004, 14:41
Kontaktdaten:

Re: Artikeltitel sind im Backend plötzlich z.T. verschwunden

Beitrag von homtata » So 13. Mär 2016, 21:40

4.8.15 ist doch schon recht veraltet - je nach PHP-Version könnte das zu Problemen führen. HostEurope zum Beispiel hat um den 08.03. rum alle Hostingpakete auf eine höhere PHP-Version gehoben - vielleicht ist es ja was in der Richtung. Ich würde sagen: Backups machen, und dann mal auf die 4.8.18 oder 4.8.20 updaten. Und dann schauen, ob die Probleme behoben sind oder nicht.

Parklife
Beiträge: 102
Registriert: Sa 19. Nov 2005, 20:28
Kontaktdaten:

Re: Artikeltitel sind im Backend plötzlich z.T. verschwunden

Beitrag von Parklife » Mo 14. Mär 2016, 10:57

homtata hat geschrieben:4.8.15 ist doch schon recht veraltet - je nach PHP-Version könnte das zu Problemen führen. HostEurope zum Beispiel hat um den 08.03. rum alle Hostingpakete auf eine höhere PHP-Version gehoben - vielleicht ist es ja was in der Richtung. Ich würde sagen: Backups machen, und dann mal auf die 4.8.18 oder 4.8.20 updaten. Und dann schauen, ob die Probleme behoben sind oder nicht.
Danke für die Antwort - ja, um den 8.3. rum traten auch die Probleme auf. Ich werde mal ein Update durchführen.

Oldperl
Beiträge: 4160
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Re: Artikeltitel sind im Backend plötzlich z.T. verschwunden

Beitrag von Oldperl » Mo 14. Mär 2016, 11:12

homtata hat geschrieben:Ich würde sagen: Backups machen, und dann mal auf die 4.8.18 oder 4.8.20 updaten. Und dann schauen, ob die Probleme behoben sind oder nicht.
Das kommt auf die dann eingesetzte PHP-Version an, denn auch die 4.8.20 ist nicht mehr uneingeschränkt kompatibel. Auch das ein oder andere "alte" Modul oder Plugin können unter einem neueren PHP entsprechende Fehler produzieren. Und dann ist da auch noch die Datenbank, bei der man zumindest auf den mysqli-Treiber setzen sollte, je nach Version aber auch da Inkompatibilitäten auftreten können.
Verschwunden Datenbankinhalte, wie hier Artikeltitel, weisen auch oft auf ein Encoding-Problem hin.

Es wäre hier definitiv hilfreich auch mal ins Contenido-Errorlog zu schauen. Gerade in der letzten Woche hatte ich beim Update auf meine ConLite 2.0 ein Errorlog welches aufgrund einer PHP-Umstellung bereits im vergangenen August auf über 1.6 GB angewachsen war. Das kann dann nicht nur zu einer Sperrung durch den Provider aufgrund von Quotas führen, es macht auch Backend und Frontend langsamer, da für jeden Eintrag ins Log dieses erst "vorgespult" werden muss.

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

rethus
Beiträge: 1847
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: Artikeltitel sind im Backend plötzlich z.T. verschwunden

Beitrag von rethus » Mo 14. Mär 2016, 13:50

Parklife hat geschrieben:Ich habe seit einigen Tagen ein Problem mit Contenido 4.8.15 - wenn ich mich einlogge (als Sysadmin oder Redakteur, das ist egal) werden nur einige der Artikel mit Titel angezeigt
Du hast ein Zeichencodierungsproblem.
In den Titeln der entsprechenden Artikel sind Sonderzeichen enthalten.

Die neue Grundkonfiguration deines neuen PHP hat scheinbar: default_charset = "utf-8" gesetzt, da 4.8 aber nicht richtig utf8 kann, werden diese nicht mehr dargestellt.
Vielleicht könntest du es übergangsweise mit einem erzwingen des Zeichensatzes via htaccess wieder lauffähig bekommen: http://floern.com/webscripting/umlautproblem (also auf iso umsetzen):

Code: Alles auswählen

default_charset = "iso-8859-1"   (php.ini)
AddDefaultCharset ISO-8859-1   (.htaccess)
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable.com: - HighSpeed Hosting, Domains, DomainReselling, Linux-Administration
suther.de: - App-Programierung, High-Performance-Webpages, MicroServices, API-Anbindungen & Erstellung

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Parklife
Beiträge: 102
Registriert: Sa 19. Nov 2005, 20:28
Kontaktdaten:

Re: Artikeltitel sind im Backend plötzlich z.T. verschwunden

Beitrag von Parklife » Mo 14. Mär 2016, 15:46

Danke für Eure Antworten - ich habe jetzt erst einmal das Update auf 4.8.20 durchgeführt, und siehe da: die Titel sind plötzlich wieder sichtbar und anklickbar. :) Ich werde aber mal schauen, wie das mit der Zeichencodierung ist, die habe ich jetzt noch nicht überprüft.

Gesperrt