TinyMCE updaten

Gesperrt
Vince
Beiträge: 122
Registriert: So 6. Mär 2005, 12:53
Kontaktdaten:

TinyMCE updaten

Beitrag von Vince » Fr 12. Feb 2016, 09:16

Hallo,

bin jetzt etwas raus, weil das System nun schon einige Jahre problemlos läuft :D

Daher brauch ich mal eine kurz Hilfestellung. Nach der Umstellung von IE8 auf IE11 funktioniert der Editor in 4.8.14 nicht mehr einwandfrei, es können z.B. keine Links mehr eingefügt werden.
Der Tiny 3.0 ist wohl zu alt. Habe jetzt den aktuellsten (4.3.4) runtergeladen.

Nun die Frage, brauchen die neuen Daten nur nach /contenido/external/wysiwyg/ kopiert werden?
Danach noch den Pfad zum Editor anpassen (contenido/includes/config.php).

Oder sind noch andere Arbeiten notwendig?

Danke schon mal

Vince

Vince
Beiträge: 122
Registriert: So 6. Mär 2005, 12:53
Kontaktdaten:

Re: TinyMCE updaten

Beitrag von Vince » Mo 15. Feb 2016, 14:23

moin,

so, hab mich mal etwas damit beschäftigt.
Hab nun mal den Tiny4 aus der Ver. 4.9.7 genommen, allerdings startet er unter 4.8.14 nicht, es gibt immer folgenden Fehlermeldung:

Code: Alles auswählen

Fatal error: Class 'cRegistry' not found in /www/htdocs/*****/contenido/external/wysiwyg/tinymce4/contenido/config.php on line 23
Muss da noch irgendwo was angepasst werden?
Ist halt blöd, wenn man sich mit PHP nicht auskennt :(

LG, Vince

Faar
Beiträge: 1720
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: TinyMCE updaten

Beitrag von Faar » Mo 15. Feb 2016, 16:01

Hallo Vince,

aktualisiere zuerst das Contenido von 4.8.14 auf 4.8.20, denn da hat sich seither sehr viel getan.
Und dann geht es nur, den TinyMCE innerhalb der 3'er Version zu updaten.

Contenido 4.8.14 und 4.9.7 lässt sich ganz schlecht bis sauschlecht miteinander kombinieren.
Wenn, dann ein umfangreiches Upgrade von 4.8.14 auf 4.8.20 und dann auf 4.9.8.

Vg,
Faar
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

Oldperl
Beiträge: 4160
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Re: TinyMCE updaten

Beitrag von Oldperl » Di 16. Feb 2016, 15:25

Faar hat geschrieben:Contenido 4.8.14 und 4.9.7 lässt sich ganz schlecht bis sauschlecht miteinander kombinieren.
Das sollte man gar nicht versuchen! Dazu hat sich im Core viel zu viel geändert. Hier den TinyMCE4-Einbau der 4.9er auf die 4.8er herunter zu migrieren ist/wäre eine Fleissarbeit, die vom Zeitaufwand wohl sogar einen entsprechenden Neueinbau des TinyMCE in die 4.8er überschreiten würde.
Man sollte da eher versuchen den Einbau der 3er Version zu nehmen und dort den 4er einzubauen.

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Gesperrt