Gelöst:Frontend wird nach Upgrade auf 4.8.20 nicht angezeigt

Gesperrt
Mc
Beiträge: 188
Registriert: Mi 2. Mär 2005, 21:19
Kontaktdaten:

Gelöst:Frontend wird nach Upgrade auf 4.8.20 nicht angezeigt

Beitrag von Mc » Sa 20. Dez 2014, 18:25

Das Problem ist gelöst: Ich bin auf Advanced Mod Rewrite umgestiegen.
Toll, wie einfach der Umstieg geht.
4.8.20 läuft einwandfrei, die Auskommentierung konnte ich zurücknehmen.
Kaspersky motzt auch nicht mehr.
Wo das Problem wirklich lag, weiß ich allerdings nicht.
Ich hatte alle txt-Dateien untersucht, verschiedene Malwar-Programme darüberlaufen lassen.
---------------------------------------------------------------------------
Ursprünglicher Eintrag:
Das Frontend wurde nach dem upgrade von 4.8.15 auf 4.8.20 nicht angezeigt.
Stattdessen Fehlermeldung: Illegal call

Nachdem ich in contenido - includes in der config.php folgende Zeile auskommentiert hatte
/*defined('CON_FRAMEWORK') or die('Illegal call');*/

ist das frontend korrekt angezeigt worden.

Der Fehler trat nur auf, wenn ich die URL http://www.webec.de eingegeben habe. Dann wurde auf das cms nicht weitergeleitet.
Bei Eingabe von http://www.webec.de/cms wurde die Seite korrekt angezeigt.

Es wäre schön, wenn mir das jemand erklären könnte.
--------------------------
Übrigens liefert Kaspersky die Fehlermeldung HEUR:Trojan.Script.Iframer bei http://www.webec.de und stoppt das laden, nicht jedoch bei http://www.webec.de/cms
Ob das mit obigem Problem zusammenhängt? Die Auskommentierung hat da jedoch nichts gebracht.

Gruß Mc
Zuletzt geändert von Mc am So 21. Dez 2014, 12:36, insgesamt 1-mal geändert.

Faar
Beiträge: 1497
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: Frontend wird nach Upgrade auf 4.8.20 nicht angezeigt

Beitrag von Faar » Sa 20. Dez 2014, 20:50

Das CON_FRAMEWORK ist zur Sicherheit, das sollte nicht auskommentiert werden.
Wenn es anschlägt, dann ist da was faul und ein fremdes Script sucht sich da einzuklinken.

Bei mir jedoch stoppt nichts, wenn ich die Seite aufrufe, die Seite lädt durch und keine fremden Scripts werden gemeldet.

Auf jeden Fall würde ich mit FTP die Verzeichnisse durcharbeiten auf Veränderungen in den Dateien (oft wird die index.php verändert) und zusätzlichen Dateien die da nicht hingehören (besonders .txt Dateien die Progerammcode enthalten).
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

Gesperrt