Bug? Apache-Absturz im Layout-Editor mit PHP 5.3.5

Gesperrt
derernst
Beiträge: 50
Registriert: Do 14. Aug 2008, 16:47
Kontaktdaten:

Bug? Apache-Absturz im Layout-Editor mit PHP 5.3.5

Beitrag von derernst » Mo 20. Jun 2011, 22:40

Hallo

Ich habe einige Contenido-Seiten, die online und auf meinem XP-Laptop problemlos laufen. Nun versuche ich, zwei davon auch auf meinem neuen Win7-Rechner zum Laufen zu bringen. Dort musste ich die neueste XAMPP-Version installieren, die hat PHP 5.3.5. Deshalb habe ich eine Site auf Contenido 4.8.15 aktualisiert, die andere läuft noch mit 4.8.12, dafür mit deaktivierten E_DEPRECATED-Meldungen.

Dieses Problem besteht auf meinem System bei beiden Contenido-Versionen:

Im Layout-Editor stürzte der Inhalts-Frame ab, sobald ich links ein Layout anklickte. Apache meldete einen "Appcrash", dann sagte Firefox, die Verbindung sei vom Server zurückgesetzt worden. Nach längerem Probieren fand ich heraus, dass das Problem mit dem Code der Layouts zu tun hat; diese beginnen mit dem folgenden Code:

Code: Alles auswählen

<?php 
$sql="select ARTLANG.pagetitle, ARTLANG.title from ".$cfg["tab"]["art_lang"]." AS ARTLANG where idart='".$idart."' and idlang='".$lang."' LIMIT 1";
$db->query($sql);
$db->next_record();
$seitentitel = trim(strip_tags($db->f("title")));
$titletag = trim(strip_tags($db->f("pagetitle")));
if ($titletag == "") $titletag = $seitentitel;
?>
Das Problem verschwindet, wenn ich diese Zeile lösche:

Code: Alles auswählen

$db->next_record();
Ich denke, man könnte dies wohl irgendwie umgehen, aber dass gerade der Apache abstürzt, ist schon recht happig! Aufgefallen ist mir überdies, dass die Syntaxeinfärbung nicht funktioniert, auch nicht z.B. bei den Modulen. Dies könnte zusammenhängen.

Ich hoffe, dass Ihr mit diesen Angaben etwas anfangen könnt, und bin gespannt, ob es dafür eine einfache Erklärung und Lösung gibt!

Hier noch die restlichen Angaben:

Server Betriebssystem Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1
PHP Datenbankerweiterung mysql
Datenbankserver-Version 5.5.8
Installierte PHP-Version 5.3.5
safe_mode Deaktiviert
magic_quotes_gpc Deaktiviert (Aktivieren macht keinen Unterschied)
magic_quotes_runtime Deaktiviert
gpc_order
memory_limit 128M
max_execution_time 30
Deaktivierte Funktionen nichts deaktiviert
Gettext Erweiterung geladen
sql.safe_mode Deaktiviert

emergence
Beiträge: 10606
Registriert: Mo 28. Jul 2003, 12:49
Wohnort: Austria
Kontaktdaten:

Re: Bug? Apache-Absturz im Layout-Editor mit PHP 5.3.5

Beitrag von emergence » Mi 22. Jun 2011, 09:28

hmm...

das -> $db->next_record();
wird hundertfach im code genutzt und macht nur an der position eine problem... ? das zu entfernen ist leider keine lösung...

wenn der apache abstürzt müsste es etwas im server log zu finden geben..
siehe server verzeichnis -> apache/logs/error.log

ich tippe auf einen bug des xampp...
würde eine andere xampp version einsetzen ..
*** make your own tools (wishlist :: thx)

derernst
Beiträge: 50
Registriert: Do 14. Aug 2008, 16:47
Kontaktdaten:

Re: Bug? Apache-Absturz im Layout-Editor mit PHP 5.3.5

Beitrag von derernst » Mi 22. Jun 2011, 11:24

emergence hat geschrieben:ich tippe auf einen bug des xampp...
würde eine andere xampp version einsetzen ..
Vielen Dank - da Xampp 1.7.4 auch noch andere Probleme hat, und ich deshalb bereits auswendig wusste, wie die Neuinstallation zu machen ist, ohne alle DBs usw. zu verlieren :roll:, fiel mir die Entscheidung leicht, deinen Rat zu befolgen. Jetzt läufts mit der 1.7.1 wieder rund!

Oldperl
Beiträge: 4160
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Re: Bug? Apache-Absturz im Layout-Editor mit PHP 5.3.5

Beitrag von Oldperl » Mi 22. Jun 2011, 17:38

emergence hat geschrieben:ich tippe auf einen bug des xampp...
würde eine andere xampp version einsetzen ..
Kein Bug in XAMPP, Contenido "kann" einfach nicht mit den Versionen von PHP und MySQL im XAMPP-Paket.
Eine ältere Version von XAMPP sollte hier die bessere Wahl sein.
Und Daumen drücken das Contenido 4.9 bald kommt. 8)

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Gesperrt