Unlöschbare Leerkategorien

Alles rund um Module und Plugins in CONTENIDO 4.10.
Antworten
Horst1234
Beiträge: 318
Registriert: Sa 25. Okt 2008, 12:45
Wohnort: Bremen
Kontaktdaten:

Unlöschbare Leerkategorien

Beitrag von Horst1234 » Fr 12. Jul 2019, 10:07

Hallo,
wenn ich leere Kategorien gelöscht habe und das Backend dann neu aufrufe, erscheinen im Kategorienbaum des Artikelbereiches immer viele leere Sppiegelstriche. Ich habe den Beispielmandanten als Vorlage genutzt und dann alles gelöscht, was ich nicht brauche.
Diese leeren Einträge verschwinden erst nach einem Frame-Reload.Und sind bei jedem neuen Backendaufruf wieder da.
conforum.JPG
conforum.JPG (11.45 KiB) 92 mal betrachtet
Das Problem hatte ich schon in 4.9, jetzt auch in 4.10.
Gibt es da eine Lösung?
Gruß aus Bremen,
Horst
Webdesign | Contenido: Templateprogrammierung, Einrichtung und Verwaltung | http://www.w2media.de

Oldperl
Beiträge: 4015
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: Unlöschbare Leerkategorien

Beitrag von Oldperl » Mo 15. Jul 2019, 17:09

Hallo Horst,

gibt es nach dem Löschen der Kategorien Meldungen im errorlog?
Ich vermute ein Problem mit der cat_tree bzw. mit dem Caching. Was passiert, wenn Du Dich ausloggst, das Cookie löschst und dann wieder einloggst?

Gruß aus Franken

Ortwin
CONTENIDO 4.9 Entwickler-Handbuch - Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x
phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Horst1234
Beiträge: 318
Registriert: Sa 25. Okt 2008, 12:45
Wohnort: Bremen
Kontaktdaten:

Re: Unlöschbare Leerkategorien

Beitrag von Horst1234 » Mo 15. Jul 2019, 17:25

Hallo Ortwin,
an den Cookies liegt es nicht, habe ich ausprobiert.
Beim Anlegen und wieder Löschen von Kategorien gibt es keinen Eintrag im Errorlog.
Aber einen weiteren leeren Spiegelstrich im Kategorienbaum ;-)
Gruß,
Horst
Webdesign | Contenido: Templateprogrammierung, Einrichtung und Verwaltung | http://www.w2media.de

Horst1234
Beiträge: 318
Registriert: Sa 25. Okt 2008, 12:45
Wohnort: Bremen
Kontaktdaten:

Re: Unlöschbare Leerkategorien

Beitrag von Horst1234 » Mo 15. Jul 2019, 17:28

Korrektur: dann entstehen keine neuen Leerkategorien, also kein neuer leerer Speigelstrich.
Kann das was mit dem Beispielmandanten zu tun haben?
Webdesign | Contenido: Templateprogrammierung, Einrichtung und Verwaltung | http://www.w2media.de

Oldperl
Beiträge: 4015
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: Unlöschbare Leerkategorien

Beitrag von Oldperl » Mo 15. Jul 2019, 18:04

Hallo Horst,

man müsste das erst mal genauer ausprobieren. Es könnte auch mit der Synchronisierung in einer 2. Sprache zu tun haben, oder mit manuellen Änderungen in den Setup-Daten (gängige Praxis momentan bei Contenido) des Demo in der Entwicklung.
Vielleicht kann ja xmurrix, wenn er das hier liest, mal ein Ticket im Bugtracker anlegen. Es braucht halt auch ein wenig (Arbeits-)Zeit um diesen Fehler vernünftig zu prüfen. Daher kann ich Dir da gerade keine schnelle Lösung anbieten.

Gruß aus Franken

Ortwin
CONTENIDO 4.9 Entwickler-Handbuch - Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x
phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

homtata
Beiträge: 1018
Registriert: Mi 14. Jan 2004, 14:41
Kontaktdaten:

Re: Unlöschbare Leerkategorien

Beitrag von homtata » Mi 17. Jul 2019, 13:08

Wir haben dazu vor einigen Wochen ja schonmal einen Thread begonnen. Ich tippe darauf, dass "ich habe gelöscht, was ich nicht brauche" heißt: du hast die englische Sprachversion irgendwie global gelöscht, aber nicht Artikel für Artikel und Kategorie für Kategorie. Und ich glaube (Arbeitshypothese), dass das Löschen der englischen Sprachversion unter Administration/Sprache einiges aus der Datenbank löscht, aber nicht alles. Und das es schlicht und ergreifend ein Problem mit einer Sprachvariablen im Backend gibt, die beim Erstaufruf über die Frames hinweg nicht korrekt gesetzt ist, so dass unter Content/Artikel beim Erstaufruf ungefiltert der Kategoriebaum so kommt, als müsste er ALLE Sprachen anzeigen (denn die Geisterkategorien stammen letztlich auch aus der englischen Sprache), und erst beim zweiten Mal filter er lang=1 korrekt durch und unterdrückt diese Kategorien auch und respektiert die sprachabhängigen Einträge aus der con_cat_lang.

Antworten