Beendigung des Supportes von PHP 5.6 und 7.0 zum Ende 2018- wie geht es weiter?

Fragen zur Installation von CONTENIDO 4.9? Probleme bei der Konfiguration? Hinweise oder Fragen zur Entwicklung des Systemes oder zur Sicherheit?
Faar
Beiträge: 1344
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: Beendigung des Supportes von PHP 5.6 und 7.0 zum Ende 2018- wie geht es weiter?

Beitrag von Faar » Mo 8. Okt 2018, 19:10

Vertraulichen Informationen nach läuft sogar die 4.9.8 auf PHP 7.2
Man muss dann nur die lästigen PHP Warnings ausschalten im Error-Level in der config.php
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

Oldperl
Beiträge: 3988
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: Beendigung des Supportes von PHP 5.6 und 7.0 zum Ende 2018- wie geht es weiter?

Beitrag von Oldperl » Mo 8. Okt 2018, 19:26

Faar hat geschrieben:
Mo 8. Okt 2018, 19:10
Vertraulichen Informationen nach läuft sogar die 4.9.8 auf PHP 7.2
Nun, ich für meinen Teil halte mich da an die offiziellen Systemanforderungen von 4fb
:arrow: https://www.contenido.org/deutsch/das-c ... index.html
und da steht weder was von 4.9.8 mit PHP > = 7 noch überhaupt etwas von PHP 7.2 für irgendeine Version.
Basta!

Gruß aus Franken

Ortwin
*NEU* PHP 7.x Community Draft von CONTENIDO 4.9 auf github
CONTENIDO 4.9 Entwickler-Handbuch - Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x
phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Oldperl
Beiträge: 3988
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: Beendigung des Supportes von PHP 5.6 und 7.0 zum Ende 2018- wie geht es weiter?

Beitrag von Oldperl » Mo 8. Okt 2018, 19:29

Servus,
tollimolli2 hat geschrieben:
Mo 8. Okt 2018, 11:04
Hallo zusammen,

ich habe das PHP-Problem durch Umstellung auf ConLite, wie von Oldperl vorgeschlagen, lösen können. Da ich noch die 4.8. Version hatte, erschien mir die Umstellung auf ConLite die einfachste. Und sie war auch einfach, alle Templates funktionieren nun mit PHP 7.2. ohne Anpassung fehlerfrei.

Ich persönlich finde Conlite für alte Contenido-Versionen eine gute Alternative.

Viele Grüße
Tollimolli
Vielen Dank für das Lob und für das tolle Feedback. Und weiterhin viel Spaß! :)

Gruß aus Franken

Ortwin
*NEU* PHP 7.x Community Draft von CONTENIDO 4.9 auf github
CONTENIDO 4.9 Entwickler-Handbuch - Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x
phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Faar
Beiträge: 1344
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: Beendigung des Supportes von PHP 5.6 und 7.0 zum Ende 2018- wie geht es weiter?

Beitrag von Faar » Di 9. Okt 2018, 09:21

Oldperl hat geschrieben:
Mo 8. Okt 2018, 19:26
Nun, ich für meinen Teil...
Der ja nun nicht unübersehbar ist :roll:
...halte mich da an die offiziellen Systemanforderungen von 4fb
Und da steht auch, dass Contenido 4.8.20 nur bis PHP 5.4 laufen würde, aber praktisch läuft es auch mit PHP 5.6 ganz gut.
Basta!
:shock:
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

Antworten