[CON-2811] cApiImgScale $wantHQ @deprecated

Alle bestätigten Fehler in CONTENIDO 4.10 (erledigte Fehler werden durch geschlossene Beiträge gekennzeichnet).
Antworten
samse
Beiträge: 48
Registriert: Di 1. Sep 2015, 09:05
Kontaktdaten:

[CON-2811] cApiImgScale $wantHQ @deprecated

Beitrag von samse » Di 26. Mär 2019, 15:13

Seit der 4.10.0 Version ist der Parameter $wantHQ als @deprecated annotiert. Das führt im phpStorm dazu, dass die ganze Methode als deprecated angesehen wird, was lästig ist. Ich könnte in der IDE natürlich diesen Fehler ausschalten, aber dann würden echte deprecated-Methoden nicht mehr angezeigt werden. Soweit ich weiss, ist es nicht möglich einen einzigen Parameter in PHP als deprecated zu vermerken, aber vielleicht wisst ihr da mehr :D

xmurrix
Beiträge: 2744
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: cApiImgScale $wantHQ @deprecated

Beitrag von xmurrix » Mi 27. Mär 2019, 10:56

Hallo samse,

soweit mir bekannt ist, kann man leider keine Parameter als @deprecated markieren. Fügt man das hinzu, wird die ganze Methode in der IDE als deprecated eingestuft. Entfernt man das, bekommt der User nicht mit, dass dieser Parameter nicht verwendet werden soll. Alternativ kann man das in der Beschreibung des Parameters hinterlegen, in der Hoffnung, dass die User das auch lesen, was aber auch nicht immer der Fall ist.

Wie dokumentierst du Funktionsparameter, die als deprecated eingestuft werden?

Gruß
xmurrix

samse
Beiträge: 48
Registriert: Di 1. Sep 2015, 09:05
Kontaktdaten:

Re: cApiImgScale $wantHQ @deprecated

Beitrag von samse » Mi 27. Mär 2019, 13:33

Ich hatte in meiner Laufbahn noch nie den fall, dass eine ein einzelner Parameter deprecated wurde, sonder nur ganze Methoden.
Vielleicht ist dieser Vorschlag: https://stackoverflow.com/a/27005644/2470685 eine geeignete Lösung?
Es ist ja nichts wirklich dringendes, es wird einfach in der IDE falsch angezeigt, was zu Verwirrungen führen kann :D

Antworten