404 Not Found nach Aktivierung von AMR

Alles rund um Module und Plugins in CONTENIDO 4.10.
Antworten
bodil
Beiträge: 280
Registriert: Fr 7. Okt 2011, 04:10
Kontaktdaten:

404 Not Found nach Aktivierung von AMR

Beitrag von bodil » Do 2. Jun 2022, 15:28

Hallo zusammen,
ich habe ein Contenido(4.10.1) neu installiert. Es ist zweisprachig, die PHP-Version ist 7.4.27.
Alles hat funktioniert, aber nach Aktivierung des AMR-Plugins führt jeder Seitenbesuch zu einem 404er Fehler.
Das Plugin hat die htaccess-Datei erstellt und ins Hauptverzeichnis kopiert, der Mandantenordner heißt cms und in der Konfiguration habe ich eingestellt, dass der URL der Name der jeweiligen Sprache vorangestellt werden soll (de/en).
Weder die einfache noch die restriktive htaccess-Date löst das Problem.
Besuche ich die Seite über eine konventionelle URL (.../cms/front_content.php?idcat= ...) wird die Seite korrekt angezeigt. Klicke ich dann auf einen Link in der Navigation, versucht der Browser eine schöne Url zu laden (.../Uerber-uns/Wer-wir-sind/index.html), zeigt dann aber die Fehlerseite (404) an.
Laut phpinfo() ist mod_rewrite aktiv. Das Error-Log bleibt leer.
Kennt jemand das Problem? Hat jemand einen Tip für mich?
Für alle Hinweise dankbar:
bodil

Faar
Beiträge: 1809
Registriert: Sa 8. Sep 2007, 16:23
Wohnort: Brandenburg
Kontaktdaten:

Re: 404 Not Found nach Aktivierung von AMR

Beitrag von Faar » Do 2. Jun 2022, 15:37

Oft liegt es daran, dass im AMR-Plugin (Backend) nicht das richtige Verzeichnis eingetragen wurde, also wie "/cms" oder "/", je nachdem, wo der Ort des htaccess sich befindet.
Wenn es dort nicht fruchtet, dann schaut man mal in die htaccess rein und prüft die Pfade, ob dort z.B. /cms steht.
Fliegt der Bauer übers Dach, ist der Wind weißgott nicht schwach.

bodil
Beiträge: 280
Registriert: Fr 7. Okt 2011, 04:10
Kontaktdaten:

Re: 404 Not Found nach Aktivierung von AMR

Beitrag von bodil » Do 2. Jun 2022, 15:44

Hi Faar,
vielen Dank für die schnelle Antwort.
Die Pfade sind m. E. aber korrekt.
Die htaccess liegt im selben Verzeichnis wie contenido/ und cms/.
Entsprechend ist der »Pfad zur .htaccess-Datei vom DocumentRoot ausgehend« mit / eingetragen.
In der htaccess-Datei steht

Code: Alles auswählen

RewriteBase /cms
Insofern: alles richtig, oder?
Grüße!
bodil

xmurrix
Beiträge: 3022
Registriert: Do 21. Okt 2004, 11:08
Wohnort: Augsburg
Kontaktdaten:

Re: 404 Not Found nach Aktivierung von AMR

Beitrag von xmurrix » Do 2. Jun 2022, 16:22

Hallo bodil,

kommt die Fehlerseite von Apache oder ist es die von CONTENIDO?

Falls Apache den Fehler liefert, kann es, warum auch immer, die Regeln in der .htaccess nicht verarbeiten. Als Ursache kann die Apache Konfiguration oder die Apache Version sein.

Falls CONTENIDO die Fehlerseiten liefert, müsste man prüfen, warum das AMR-Plugin die Seiten nicht auflösen kann.

Gruß

xmurrix

bodil
Beiträge: 280
Registriert: Fr 7. Okt 2011, 04:10
Kontaktdaten:

Re: 404 Not Found nach Aktivierung von AMR

Beitrag von bodil » Do 2. Jun 2022, 16:43

Hi xmurrix!
Vielen Dank für deine Antwort!
Die Seite kommt vom Apache. Allerdings gibt es auf demselben Server bereits eine Contenido-Version (4.8 ) wo all das funktioniert. Woraus ich (zugegebenermaßen nicht die hellste Kerze im Serverraum) darauf geschlossen habe, dass das auf der neuen Seite (4.10.1) eigentlich auch alles gehen sollte.
(Um Verwirrungen vorzubeugen: das 4.10.1er System ist eine Neuinstallation, kein Update.)
Aber es scheint tatsächlich, als läge es am Server. Entweder ignoriert der Server die htaccess-Datei oder er hat Probleme mit dem mod_rewrite.
Finde ich raus! Vielen Dank!
bodil

Antworten