[con4.10.x] Bug include enviroment.php

Fragen zur Installation von CONTENIDO 4.10? Probleme bei der Konfiguration? Hinweise oder Fragen zur Entwicklung des Systemes oder zur Sicherheit?
Antworten
mattmarr
Beiträge: 342
Registriert: Mo 3. Aug 2009, 14:11
Kontaktdaten:

[con4.10.x] Bug include enviroment.php

Beitrag von mattmarr » Fr 24. Jan 2020, 09:13

Hallo Gemeinde!


In den Dateien "contenido/external/frontend/dbfs.php" und "contenido/external/frontend/front_content.php" ist ein "../../" zuviel und führt dazu, das wenn man einen neuen Mandanten anlegt, dieser nicht funktionieren kann, da an falscher Stelle nach "enviroment.php" gesucht wird und Contenido mit Fehler abbricht.
Ich glaub nicht das das gewollt ist.
Dieser Bug ist in der Zip zu 4.10.0 und 4.10.1 vorhanden.

Origianal:

Code: Alles auswählen

// Include the environment definer file
include_once($frontend_path . '../../environment.php');
Korrekt:

Code: Alles auswählen

// Include the environment definer file
include_once($frontend_path . 'environment.php');

Gruß vom Bug-Hunter :)
Matthias

Antworten