MetaTag...

Contenider
Beiträge: 503
Registriert: Do 6. Apr 2006, 01:40
Kontaktdaten:

Beitrag von Contenider » Fr 29. Sep 2006, 11:59

Halchteranerin hat geschrieben:Aehm, du hast aber schon gesehen, dass der letzte Beitrag ueber 2 Jahre alt ist? :mrgreen:
Jupp, wenn sich jemand diesen Thread durchliesst, ist er in jedem Fall schlauer, so wie Du, :arrow: Du hast ihn ebenfalls gelesen :lol:
Ειμαστε στη μεση απο κατι...

Contenider
Beiträge: 503
Registriert: Do 6. Apr 2006, 01:40
Kontaktdaten:

Beitrag von Contenider » Mo 13. Nov 2006, 12:07

Ich muss dieses Thema leider wieder aufgreifen. Aus irgendeinem Grund wird in der aktuellen und offiziellen 4.6.15 in den automatisch generierten Metatags wieder Mist ausgegeben, siehe folgender Auszug im original:

Code: Alles auswählen

<head>
<base href="http://www.url.tld/cms/">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Title</title>
<link href="css/css.css" rel="stylesheet" type="text/css" />
<meta name="author" content="Author">
<meta name="date" content="2006-11-09">
<meta name="revisit-after" content="0">
<meta name="robots" content="index, follow">
<meta name="generator" content="CMS Contenido 4.6.15">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
Was stört ist dass <base> nicht mit einem "/" abgeschlossen wird, gleiches gilt für <meta name="generator". Dies führt bei der Überprüfung auf Validität zu unschönen Ergebnissen.

Ich hatte bereits schon einmal die entsprechende Datei gefunden bzw. die entsprechenden Zeilen, wie bereits von "arakis" beschrieben, und manipuliert. In der functions.con.php unter contenido/includes kann ich die Generierung der Metatags nur leider nicht wieder finden. Bin ich zu blöd? Kann es sein dass diese jetzt anderswo geändert werden muss?
Ειμαστε στη μεση απο κατι...

Dodger77
Beiträge: 3625
Registriert: Di 12. Okt 2004, 20:00
Wohnort: Voerde (Niederrhein)
Kontaktdaten:

Beitrag von Dodger77 » Mo 13. Nov 2006, 12:27

Maron Chatzifrantzis hat geschrieben:Kann es sein dass diese jetzt anderswo geändert werden muss?
"Administration -> Mandanten -> XHTML erzeugen" sollte ausreichen

Contenider
Beiträge: 503
Registriert: Do 6. Apr 2006, 01:40
Kontaktdaten:

Beitrag von Contenider » Mo 13. Nov 2006, 17:53

Danke, das war's.
Ειμαστε στη μεση απο κατι...

rheinländer
Beiträge: 19
Registriert: Sa 30. Dez 2006, 12:11
Kontaktdaten:

generator-Tag in 4.6.15 entfernen

Beitrag von rheinländer » Mi 3. Jan 2007, 12:42

Und wer in 4.6.15mr den "generator"-Tag raus haben möchte, findet das ganze unter /contenido/includes/functions.con2.php und dort in Zeile 437:

/* $metatags[] = array ('name' => 'generator', 'content' => 'CMS Contenido '.$cfg['version']); */

Und nicht vergessen, den Inhalt der Tabelle con_code zu löschen.

Und aufgepasst, so geht das mit dem "richtigen" löschen der con_code:

Code: Alles auswählen

delete from con_code;
UPDATE con_cat_art SET createcode = '1'; 
So hat´s zumindest bei mir geklappt. Verwende aber die MR-Version von polycoder, ich weiss nicht ob die Zeilenangabe oben auch bei der normalen Version stimmt.

ClemensSchnitzler
Beiträge: 137
Registriert: Di 17. Aug 2004, 12:32
Kontaktdaten:

Darstellungsproblem

Beitrag von ClemensSchnitzler » So 11. Mär 2007, 15:04

Ich habe ein Darstellungsproblem mit Umlauten und Sonderzeichen. Sie folgender Post http://www.contenido.org/forum/viewtopic.php?t=15963
per Webgrab habe ich eine Tabelle auf einer externen Webseite in meine zu bearbeitende Seite integriert. Das klappt wunderbar, bis auf die Darstellung der Umlaute und diverser Sonderzeichen. Ich habe schon im Header von charset=iso-8859-1 zu z. B. utf-8 gewechselt, konnte damit aber leider keine Änderung erreichen.

Das Original findet Ihr unter folgendem Link:
http://www.sis-handball.de/SIS/HANDBALL ... E=/sis.css

Die "gegrabte Seite findet Ihr hier:
http://handball.c-schnitzler.de/spielte ... 7/damen-i/

Es wäre nett, wenn Ihr Euch das mal anschauen und mir weiterhelfen könntet.

Vielen Dank

Gruß

Clemens
Nun habe ich festgestellt, dass Contenido durch den Metatag-Generator meine charset-Vorgaben immer wieder überschrieben hat. Ich habe utf8 wegen meines Problems definiert und Contenido hat im Quelltext immer wieder iso.... generiert.

Den Metatag-Generator habe ich nun wie hier beschrieben "eleminiert". Die con-code Tabelle ist geleert, der Oder des Cache ist gelöscht. Trotzdem bekomme ich immernoch falsche Zeichen angezeigt.

Wenn ich den Quelltext der Seite intern speichere und dann im Browser öffne werden die Zeichen korrekt dargestellt. Auch wenn ich diese html-Datei auf den Server lade ist und dann anschaue ist die Darstellung der Sonderzeichen korrekt.

In Contenido passiert irgend etwas, wodurch die Darstellung der Sonderzeichen nicht korrekt ist.

Die Links oben im Zitat sind noch gültig. Die korrekte Darstellung der per Quelltext gespeicherten Datei findet Ihr hier:
http://handball.c-schnitzler.de/mainz05/damen.HTML

Vielleicht kann mir Jemand sagen was, damit ich weis wo ich eingreifen muss.

Gruss

Clemens

Gesperrt