Original AdvancedMod Rewrite 4.6.23

malsdgtac
Beiträge: 687
Registriert: Fr 12. Mär 2004, 15:50
Kontaktdaten:

Beitrag von malsdgtac » Di 25. Mär 2008, 21:04

Hallo,

ich habe in der letzten Zeit einige Updates von 4.4 auf 4.6.23 gemacht - jedes Mal ohne große Probleme.

Heute habe ich ein Update von 4.6.8 auf 4.6.23 gemacht - und hier wurde plötzlich meistens die Startseite statt die entsprechende Seite angezeigt.

Ich habe jetzt die Einstellung category_resolve_min_percentage 50 vorgenommen damit scheint es jetzt zu funktionieren. Mit 75 gibt es immer noch Probleme.

Kann mir jemand sagen ob es diesbezüglich von 4.6.8 auf 4.6.23 Änderungen gab, bzw. was der Wert überhaupt angibt?

Ich verwende in diesem Projekt nur deutsche Seiten

malsdgtac
Beiträge: 687
Registriert: Fr 12. Mär 2004, 15:50
Kontaktdaten:

Beitrag von malsdgtac » Di 25. Mär 2008, 21:22

Hallo ich glaube ich habe den Fehler gefunden, ich hatte die Dateien im root von cms nicht hochgeladen.

Trotzdem würde mich noch die Info bezüglich der Einstellung interessieren

Hammy
Beiträge: 26
Registriert: Sa 26. Jan 2008, 23:32
Kontaktdaten:

Beitrag von Hammy » Mi 26. Mär 2008, 02:01

ich habe nun versucht 4.6.23MR zu installieren, das Ergebnis ist, dass er mir immer die URL umbiegt, wenn ich nur www.domain.de/ aufrufe:

Aus http://www.domain.de

wird

http://www.domain.de/cms/http://www.dom ... ontent.php

Woran könnte das liegen?

wosch

Beitrag von wosch » Do 27. Mär 2008, 15:11

In der Version 4.6.23 MR läßt sich im dbfs-System kein Ordner anlegen.
Egal ob mr aktiviert ist oder nicht.

In einer "normalen" 4.6.23-Version ohne mr (auf der gleichen XAMPP installiert) ist das kein Problem.

Hammy
Beiträge: 26
Registriert: Sa 26. Jan 2008, 23:32
Kontaktdaten:

Beitrag von Hammy » Do 27. Mär 2008, 20:53

gibt es eigentlich noch support? Ich weiß, dass es alles in der Freizeit programmiert wird, aber momentan habe ich das Gefühl, dass die Entwicklung bei Contenido immer mehr "eingestampft" wird. Es sollte doch mal eine Lösung entwickelt werden, so dass ModRewrite ins Stable mit aufgenommen werden kann. Wird daran noch gearbeitet? Wann kann man mit einer neuen Version rechnen?

wosch

Beitrag von wosch » Do 27. Mär 2008, 21:47

Hammy hat geschrieben:gibt es eigentlich noch support?
Jain.
@steese, der die ganze Modrewrite-Geschichte bis zur Version 4.6.15 betreut hat, hat aufgegeben - aus Zeitgründen und Arbeitsüberlastung.
@mvf, der diese Version nach @steeses Arbeitsweise umgesetzt hat - ???
Hammy hat geschrieben:Wird daran noch gearbeitet?
Wer sollte woran arbeiten?
Hammy hat geschrieben:Wann kann man mit einer neuen Version rechnen?
Das steht in den Sternen.
Und ob in einer "neuen" Version direkt das mod_rewrite integriert ist?
Ich galube nicht dran.
Optik im Backend hat wohl eine höhere Priorität.

Hammy
Beiträge: 26
Registriert: Sa 26. Jan 2008, 23:32
Kontaktdaten:

Beitrag von Hammy » Do 27. Mär 2008, 21:58

HerrB meinte auf Seite 1 dieses Threads:
Ich kenne bereits eine dritte Variante, die in Arbeit ist.

Die einfache Lösung (die aber halt Zeit kostet): Es wird ein Plugin, so dass man nach Möglichkeit die für seine Anforderungen optimale mr-Variante einsetzen kann. Und genau daran wird gearbeitet.
Also es soll anscheinend an einer anderen Lösung gearbeitet werden. Und die Frage war, ob es tatsächlich noch so ist, da ich schon länger nichts mehr davon gehört habe, bzw. der Eintrag ja schon älter ist.

Die Frage für mich ist, ob ich Contenido noch für Websites einsetzen kann, da ich momentan von der Weiterentwicklung nicht so überzeugt bin. Bisher gefiel mir Contenido von allen CMS eigentlich am Besten und würde es auch gerne beibehalten, aber das auch in der aktuellsten Version (4.6.23) und am Besten mit MR... Denn alles andere ist mir zu riskant und ohne MR nicht das Wahre... Aber anscheinend gibt es noch ein paar Probleme bei dem Version, sodass ich fast gezwungen bin entweder die alte Version 4.6.15 einzusetzen oder auf Joomla oder ähnliches umzusteigen...

Contenider
Beiträge: 503
Registriert: Do 6. Apr 2006, 01:40
Kontaktdaten:

Beitrag von Contenider » Sa 29. Mär 2008, 16:13

Ich empfehle ja immer noch http://contenido.org/forum/viewtopic.php?t=18762, da kann man (fast) den ganzen Verlauf um die Diskussion zur Weiterentwicklung von Contenido nachlesen.
Ειμαστε στη μεση απο κατι...

GaMbIt_
Beiträge: 674
Registriert: Do 16. Mär 2006, 16:17
Kontaktdaten:

Beitrag von GaMbIt_ » Sa 29. Mär 2008, 17:28

@Contenider

Was hat das jetzt zu der Frage beizutragen??

anubis2k
Beiträge: 50
Registriert: Fr 27. Jul 2007, 13:39
Kontaktdaten:

Beitrag von anubis2k » Mo 31. Mär 2008, 08:01

Hm.. also sehe ich das richtig das die ModRewrite für Suchmaschinen
freundliche URLs in der v4.6.23 noch nicht funktioniert?!?

Das wäre echt schade :(
Auftrag ist nämlich diese Woche eine kleine Homepage (5 html Seiten)
in ein CMS um zu setzen.. da würde ich schon ganz gerne die v4.6.23 nutzen.

Mfg. Anubis

Brazo Alkher
Beiträge: 103
Registriert: Fr 28. Jan 2005, 15:15
Wohnort: Unna
Kontaktdaten:

Beitrag von Brazo Alkher » Mo 31. Mär 2008, 08:51

anubis2k hat geschrieben:Hm.. also sehe ich das richtig das die ModRewrite für Suchmaschinen
freundliche URLs in der v4.6.23 noch nicht funktioniert?!?
Also ich habe mittlerweile bei 4 Projekten die 4.6.23mr Version am laufen. Dabei auch eine Seite mit mind. 3.000.000 Seitenzugriffen pro Monat

tono
Beiträge: 574
Registriert: Mo 25. Apr 2005, 20:51
Wohnort: Frankfurt am Main
Kontaktdaten:

Beitrag von tono » Mo 31. Mär 2008, 09:14

anubis2k hat geschrieben:Hm.. also sehe ich das richtig das die ModRewrite für Suchmaschinen
freundliche URLs in der v4.6.23 noch nicht funktioniert?!?
Ich hab auch bei 3 Seiten noch keine Probleme festgestellt.
Bis dann
Tono

anubis2k
Beiträge: 50
Registriert: Fr 27. Jul 2007, 13:39
Kontaktdaten:

Beitrag von anubis2k » Mo 31. Mär 2008, 11:13

Alles klar, dann versuche ich es mal.. :)

Runtergeladen ist es schon.. da ich nur DSL384 habe, läuft der Upload noch..
Oder muss ich erst eine normale 4.6.23 installieren und dann die Dateien überschreiben?

Edit: Muss ich noch irgend etwas beachten etc.?
Noch zeigt er mir ja die URL wie folgt an ...cms/front_content.php?idcat=57

anubis2k
Beiträge: 50
Registriert: Fr 27. Jul 2007, 13:39
Kontaktdaten:

Beitrag von anubis2k » Di 1. Apr 2008, 07:31

Hm.. Hat denn niemand eine Idee für mich zur Hand?
Ich hab schon den WebSpace geprüft.. ModRewrite ist aktiv.

Könnte es vielleicht daran liegen das der FTP Pfad zZ. zu meinem
CMS wie folgt aussieht..
- html/cms/cms
- html/cms/contenido
- html/cms/...

Im root ist zur Zeit noch die Original Seite ohne CMS,
daher hab ich das System in einen Unterordner geschoben.

und zZ. hab ich eine .htaccess in html/ und in html/cms/

Hoffe mir kann einer einen Tipp geben :)

Brazo Alkher
Beiträge: 103
Registriert: Fr 28. Jan 2005, 15:15
Wohnort: Unna
Kontaktdaten:

Beitrag von Brazo Alkher » Di 1. Apr 2008, 08:12

anubis2k hat geschrieben:Edit: Muss ich noch irgend etwas beachten etc.?
Noch zeigt er mir ja die URL wie folgt an ...cms/front_content.php?idcat=57
also generell muss du an zwei Stellen das mr aktivieren
einmal in der contenido\includes\config.php

Code: Alles auswählen

$cfg['mod_rewrite']['use'] = 1;
und dann in der .htaccess

Code: Alles auswählen

RewriteEngine on
und dann muss der WebServer natürlich die RewriteEngine auch verfügbar haben. Beim Apache2 unter Win wäre das folgende Zeile in der httpd.conf

Code: Alles auswählen

LoadModule rewrite_module modules/mod_rewrite.so
dann sollte es eigentlich klappen ;-)

Gesperrt