Modul: Newsletter-Module ab V4.6.22

BLADE
Beiträge: 13
Registriert: Mi 13. Jul 2005, 20:51
Kontaktdaten:

newsletter aus email erstellen und an user verschicken

Beitrag von BLADE » Fr 11. Jul 2008, 15:14

hallo
hab mal ne frage und zwar weiss jemand wie ich mit einer email den newsletter erzeugen kann und dann an die user rausgeschickt wird?
also ich schick die mail an eine bestimmte adresse und wird als newsletter weiter geschickt praktisch ne mailingliste oder kennt jemand sowas?
ich find im internet nur mailinglisten bei denen die mail webbassiert erstellt und versendet wird!
bin schon langsam am verzweifeln... :(

danke fürs erste
BLADE

bluefin
Beiträge: 67
Registriert: Mi 9. Nov 2005, 19:51
Kontaktdaten:

Re: Modul: Newsletter-Module ab V4.6.22

Beitrag von bluefin » Do 11. Sep 2008, 09:25

nach Update von 4.6.15 auf 4.6.24 hat alles funktioniert. Super Modul!!
Gibt es die Möglichkeit, wenn ja wie, dass der Admin per Mail benachrichtigt wird, wenn ein neuer Newsletterempfänger sich angemeldet hat?

Gruß

teon
Beiträge: 4
Registriert: Mi 18. Jul 2007, 09:45
Kontaktdaten:

Leere E-Mail bei Zweitsprache

Beitrag von teon » Di 21. Okt 2008, 19:03

Hallo!

Ich habe ein kleines Problem mit dem Newsletter-Modul.

An und Abmeldung funktionieren einwandfrei und auch der Versand von Text- und HTML-Mails im englischen Backend funktioniert.

Wenn ich jetzt aber im backend nach Deutsch wechsle, funktionieren nur noch die Text-Mails. Versende ich ein HTML-Mail als Testnachricht, dann erhalte ich nur ein leeres E-Mail. Im Backend wird die Nachricht aber noch vollständig angezeigt.

Die Einstellungen sind bei beiden Sprachen gleich. Habt ihr eine Idee???

Vielen Dank im Voraus!!!
Thomas

Ergänzung: Mir ist gerade aufgefallen, dass sich in Deutsch auch keine Versandjobs erstellen lassen.

rethus
Beiträge: 1827
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Class itemcollection: No table specified. Inherited classes

Beitrag von rethus » Di 28. Okt 2008, 12:52

Den folgenden Fehler erhalte ich, wenn ich im Formular meinen namen und Email eintrage und auf absenden klicke:

Code: Alles auswählen

Class itemcollection: No table specified. Inherited classes *need* to set a table
Gehe ich in den Adminbereich in Newsletter >> Benutzer "Neuer Nutzer erzeugen, erhalte ich die gleiche Meldung.

Ich bin nach Anleitung der ersten Seite vorgegangen.

Kürzlich habe ich versucht die Version 4.1.18 auf 4.8.6 zu aktualisieren, was leider nicht gelang (serverkonfig), daher ist nun die 4.6.23 drauf, wobei die DB aber nicht upgedatet wurde.

kann es sein, das der Newsletter neue DB-Tabellen erhalten hat?
Wenn ja, wie kann ich vom alten Newsletter auf den neuen Migrieren?
Weiß jemand woran das leigen könnte?
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

rethus
Beiträge: 1827
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Beitrag von rethus » Fr 31. Okt 2008, 21:42

Ich hab es soweit eingegrenzt, dass der Fehler beim Handlermodul auftritt. Uns zwar bei folgendem Aufruf:

Code: Alles auswählen

$recipient = $oRecipients->create($sEMail, $sName, 0, "", $iMessageType);
Es waren zudem nicht alle con_news...-Tabellen in der Datenbank vorhanden. Die Frage aller Fragen ist nun, ob ich gefahrlos das Setup ausführen kann und somit die 4.6.24er Versioni drüber bügeln kann.

Die 4.8.8er geht leider nicht, weil auf dem Server kein php5 läuft.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Schnuffel21
Beiträge: 2
Registriert: Mo 3. Nov 2008, 18:41
Kontaktdaten:

Call to undefined function: str_split()

Beitrag von Schnuffel21 » Mo 3. Nov 2008, 18:47

Hallo zusammen,

habe folgendes Problem beim Newsletter Import V4.6.23.
Beim Aufruf der Funktion Empfänger importieren erscheint folgende Fehlermeldung:
Fatal error: Call to undefined function: str_split() in /mnt/webX/XX/XX/XXXXXXXX/htdocs/contenido/includes/include.recipients_import.php on line 127

Kann ich den Fehler beheben, ohne Neuinstallation?
Und wenn ja, wie.

Vielen Dank im voraus für Hilfe :)

rethus
Beiträge: 1827
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Beitrag von rethus » Di 4. Nov 2008, 11:00

Er schreibt, dass Ihm die Funktion die dort aufgerufen wird fehlt.

Hast du kürzlich ein Upgrade gemacht? Ggf. müsstest du die Newsletter-Klassen nochmal neu auf den Server kopieren (natürlich von den alten Dateien ein Backup machen).
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

rethus
Beiträge: 1827
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Beitrag von rethus » Di 4. Nov 2008, 13:09

Ein Upgrade des gesamten Contenidosystems auf 4.6.24 hat die Probleme gelöst.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Schnuffel21
Beiträge: 2
Registriert: Mo 3. Nov 2008, 18:41
Kontaktdaten:

Beitrag von Schnuffel21 » Di 4. Nov 2008, 16:37

Hallo rethus,

hab den Fehler gefunden. :D
Contenido lief noch mit der php-Version 4.4.1.
Die Funktion str_split() gibt es erst ab php-Version 5.

Danke trotzdem für Deine schnelle Antwort.

diefl
Beiträge: 34
Registriert: Mi 29. Jun 2005, 16:04
Kontaktdaten:

Versandjobs werden nicht mehr erzeugt

Beitrag von diefl » Mo 17. Nov 2008, 17:04

Hallo zusammen,
ich habe ein Problem beim Erzeugen von Versandjobs für den Newsletter (Contenido 4.6.24).

Nachdem das Newsletter-System bislang (8 Montate) einwandfrei gelaufen ist, kann ich neuerdings keine Versandjobs mehr erzeugen, die mehr als 7 Empfänger (ist eine Testgruppe, vielleicht gehen auch ein paar mehr) enthalten.
Ich habe 5 Grupen mit je ~500 Empfängern, Versandjob erzeugen und Versand in Blöcken funktionierte bislang problemlos, auch wenn das Erzeugen der Jobs immer recht lange (~1 Min.) gedauert hat. Am System wurde nichts geändert.

Wenn ich versuche einen Versandjob zu erzeugen, passiert nichts - ich würde mich ja schon über eine Fehlermeldung freuen.

Allerdings wird wohl versucht, einen Job anzulegen - in der "con_news_jobs" sehe ich neue Einträge:

Bis auf das Feld idnewsjob (dort wird die fortlaufende id erzeugt) und den Newslettertyp (der falscherweise als "txt" angegeben wird) werden ALLE anderen Felder mit "0" resp. "Null" belegt, das timestmap in "newsdate" 0000-00-00 00:00:00.

Die DB-Einträge für die Testgruppe mit den wenigen Empfängern sieht "normal" aus, diesen Newsletter kann ich dann auch problemlos versenden.

Ach so: Die max_execution_time liegt bei 90 sek; das sollte doch eigentlich reichen (hat es vorher ja auch) ?

Hat jemand einen Tip?

Danke für eure Hilfe!

Vetinari
Beiträge: 136
Registriert: Sa 31. Mär 2007, 19:11
Wohnort: Fulda
Kontaktdaten:

Re: Modul: Newsletter-Module ab V4.6.22

Beitrag von Vetinari » Do 21. Mai 2009, 20:11

hallo leute,

ich habe 3 empfänger gruppen für einen monatlichen newsletter. die empfänger werden vor dem versand aus dem adress-bestand von 2 unterschiedlichen software-produkten extrahiert.
bislang habe ich ein eigenes script genutzt, welches u.a. auch folgendes erledigt:

- falsche e-mail adressen werden eliminiert
- beim versand an mehr als eine gruppe werden doppelte e-mail adressen gelöscht (und davon gibt es viele!)
- im newsletter wird automatisch ein unsubscribe link erzeugt

kann dieses newsletter modul von contenido das auch - insbesondere die zweite funktion? unsubscribe geht ja wohl auch, aber wie funktioniert es genau?

gruss, martin
Si non confectus, non reficiat. (Motto der Vetinaris)
Solange etwas nicht kaputt ist, repariere es nicht.
oder:
Lass die Dinge einfach laufen, die meisten Probleme erledigen sich eh von selbst.

Vetinari
Beiträge: 136
Registriert: Sa 31. Mär 2007, 19:11
Wohnort: Fulda
Kontaktdaten:

Re: Modul: Newsletter-Module ab V4.6.22

Beitrag von Vetinari » Di 26. Mai 2009, 10:33

hallo,

komme soweit klar, dass ich eben nur eine gruppe nutze, damit haben sich die punkte 1+2 von meiner liste erledigt.

habe jetzt 1500 empfänger drin, aber leider vergessen, sie alle auf nachrichtentyp "HTML und Text" zu setzen. die empfänger mit dem neuen nachrichtentyp zu überschreiben funktioniert nicht. ich vermisse eine löschfunktion für alle empfänger :?

gruss, martin
Si non confectus, non reficiat. (Motto der Vetinaris)
Solange etwas nicht kaputt ist, repariere es nicht.
oder:
Lass die Dinge einfach laufen, die meisten Probleme erledigen sich eh von selbst.

Vince
Beiträge: 122
Registriert: So 6. Mär 2005, 12:53
Kontaktdaten:

Re: Modul: Newsletter-Module ab V4.6.22

Beitrag von Vince » Do 24. Sep 2009, 17:07

moin,

nice little problem :wink:

Ich hab den Newsletter installiert und konfiguriert (Contenido 4.6.24), funktioniert auch alles bestens - dachte ich.
Nach dem erfolgreichen Versand eines Test-Newsletters wollte ich mal einen echten wegschicken.

Hab dann einen erstellt und einen Versand-Job erzeugt. Der steht jetzt schon seit Tagen auf "Warte auf Versand".
Ich dachte, der würde dann durch einen der Pseudo-Crons irgendwann automatisch rausgeschickt.
Woran kann es denn nun liegen, das sich nichts tut?

Danke schon mal für ein wenig Unterstützung.

Vince

conradius
Beiträge: 168
Registriert: Di 19. Jul 2005, 11:52
Wohnort: Wabern (Bern/CH)
Kontaktdaten:

Re: Modul: Newsletter-Module ab V4.6.22

Beitrag von conradius » Di 29. Sep 2009, 13:50

Vince hat geschrieben:Hab dann einen erstellt und einen Versand-Job erzeugt. Der steht jetzt schon seit Tagen auf "Warte auf Versand".
Ich dachte, der würde dann durch einen der Pseudo-Crons irgendwann automatisch rausgeschickt.
Hast du denn den Job versandt? Scrolle dazu mal ganz nach rechts in der linken Spalte, wo die Jobs aufgelistet werden...
Und dann musst du - glaube ich - das Fenster während dem gesamten Versand offen lassen.

Hilft das?
Gruss
Conrad

Vince
Beiträge: 122
Registriert: So 6. Mär 2005, 12:53
Kontaktdaten:

Re: Modul: Newsletter-Module ab V4.6.22

Beitrag von Vince » Di 29. Sep 2009, 13:59

Hi Conrad,

ich danke dir :D

Konnte die Buttons hinter den Jobs nicht sehen und hab auch nicht gepeilt, dass man noch weiter nach rechts scrollen kann.
Hat jetzt geklappt. Super.

Vielen Dank für deine Hilfe.

Vince

Gesperrt