Plugin: Umfrage

Oldperl
Beiträge: 4122
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Beitrag von Oldperl » Do 28. Aug 2008, 15:14

Hallo Steffen,

folgende Konstante in der install.php zu Beginn definieren

Code: Alles auswählen

define("CON_FRAMEWORK", true);
nun sollte die Installation funktionieren. ;-)

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Rene B
Beiträge: 1
Registriert: Mi 3. Sep 2008, 09:00
Kontaktdaten:

Beitrag von Rene B » Mi 3. Sep 2008, 10:19

Ich hab das Plugin auch versucht auf der neuen Version 4.8.7 zu installieren. Hab dann auch die letzten Beiträge befolgt.
Jetzt habe ich, wenn ich die install.php aufrufe die Fehlermeldung:

Fatal error: Class 'Contenido_Security' not found in /data/cms/contenido/classes/class.cec.php on line 46

Weiß jemand Rat und kann mir weiterhelfen?

Vielen Dank im Voraus!


Gruß
René

20082009
Beiträge: 116
Registriert: So 5. Okt 2008, 09:58
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von 20082009 » Fr 10. Okt 2008, 10:03

Hallo- funktioniert prima!!!
gibt es eine Lösung, wenn ich die Internetseite 2 sprachig angelegt habe, und ich die Umfrage in der entsprechenden Sprache haben möchte?

Danke.

vpanama
Beiträge: 26
Registriert: Mo 3. Dez 2007, 19:21
Kontaktdaten:

Hallo

Beitrag von vpanama » Di 11. Nov 2008, 14:55

Hallo,

ist das Tool nun auch für 4.8.8 geeignet und welche Pfade müssen nun in welcher Datei personalisiert werden?

In der install.sql hab ich alles mit !PREFIX!_ geändert auf con_ . An welcher Stelle muss ich das für die anderen Kofigdateien tun? Ich hab in der config.plugin.php noch sowas $cfg['plugins']['poll'] = $cfg['path']['plugins'].$plugin_name."/"; Auf was muss ich den path ändern? http://www.Domain.de/con/contenido ...?
Vielen Dank für entsprechende Antworten.
Schönen Tag

vpanama

Vince
Beiträge: 122
Registriert: So 6. Mär 2005, 12:53
Kontaktdaten:

Beitrag von Vince » Mo 15. Dez 2008, 11:54

moin,

ich hab das Poll-Script installiert, kriegte es aber nicht richtig zum laufen. Hab dann alles wieder runtergeschmissen und die geänderten Dateien (wegen i18n) wieder mit den vorherigen überschrieben. Die angelegten Tables sind ebenfalls gelöscht.

Nur, das Backend funktioniert nun nicht mehr :(
Es kommt immer der Fehler
"Unable to load polls/xml/ XML language file"
an der Stelle, wo man normalerweise die Artikel auswählt.
Hab mal die Datei mitsamt Pfad wiederhergestellt, ändert sich aber nix.

Wie krieg ich das weg, damit man wieder mit dem CMS arbeiten kann?

thanx, Vince

Oldperl
Beiträge: 4122
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Beitrag von Oldperl » Mo 15. Dez 2008, 13:54

Hallo Vince,

Plugins in Contenido sollten über die install.php im Pluginverzeichnis deinstalliert werden, da dabei in verschiedenen DB-Tabellen zusätzliche Änderungen gemacht werden.
Mein Vorschlag, lade alle Dateien des Plugins nochmal hoch und rufe die install.php nochmals auf. Solange du keine Änderungen in der Tabelle con_plugins gemacht hast, sollte dir bei diesem Aufruf die Möglichkeit zum Update oder zum Löschen des Plugins angeboten werden. Die dafür notwendigen Infos was/wo gelöscht werden muss in der DB steht ebenfalls in der Tabelle con_plugins und diesen Eintrag nutzt die Funktion zum Deinstallieren.

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

knb
Beiträge: 224
Registriert: Fr 9. Sep 2005, 14:03
Wohnort: Potsdam
Kontaktdaten:

Beitrag von knb » Fr 9. Jan 2009, 13:02

@Vince:
du hast wahrscheinlich eine andere Sprache als "deutsch" in deinem Backend.

In folgendes Verzeichnis wechseln:
contenido/plugins/polls/xml

File lang_de_DE.xml kopieren in deine Backend Default Sprache
cp lang_de_DE.xml lang_en_US.xml
- oder was auch immer deine Sprache ist. Mal alle "locale" Verzeichnisse deiner Contenido Installation durchsuchen.

Optional: Inhalt vom XML File in Deine Zielsprache übersetzen (enthält nur ein einziges Wort, "Umfrage")
Gruss,
Knut

Oldperl
Beiträge: 4122
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Beitrag von Oldperl » Sa 10. Jan 2009, 00:05

Hallo Knut
knb hat geschrieben:@Vince:
du hast wahrscheinlich eine andere Sprache als "deutsch" in deinem Backend.
Nein hat er nicht, er hat das Plugin händisch entfernt. Und genau das hat er auch geschrieben.
Vince hat geschrieben:Hab dann alles wieder runtergeschmissen...
Er hat zwar die zusätzlich angelegten DB-Tabellen gelöscht, aber nicht die Einträge in den Contenido-Tabellen. Dort wird zum Beispiel der Pfad zu den xml-files mit eingetragen. Und wenn der drin steht, aber kein xml-file vorhanden ist, gibt es besagte Fehlermeldung. Deinstallation von Plugins sollte man immer mit dem Install-Script machen.

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

20082009
Beiträge: 116
Registriert: So 5. Okt 2008, 09:58
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von 20082009 » Mi 25. Mär 2009, 20:17

Hallo zusammen,
gibt es ein funktionierendes Umfrage Modul für die Contenido Version 4.8.11??

Oder was genau muss ich an dem hier aufgeführten Modul anpassen?


Beste Grüße

Liquidstone
Beiträge: 36
Registriert: Di 12. Aug 2008, 10:27
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von Liquidstone » Di 7. Jul 2009, 09:12

Ich wollte das Modul gerade runterladen aber der Link scheint wohl Down zu sein !?
Gibt es einen neuen Link???

sherman
Beiträge: 40
Registriert: Mi 29. Nov 2006, 00:44
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von sherman » Mo 9. Nov 2009, 16:52

Ich habe versucht das plugin unter 4.8.12 zu installieren und bekomme auch den Fehler bei der Installation:

Fatal error: Class 'Contenido_Security' not found in /homepages/20/d264180393/htdocs/testcms/contenido/classes/class.cec.php on line 68

Habe schon - wie von oldperl - beschrieben die Konstante definiert (define("CON_FRAMEWORK", true);).

Hat jemand eine Idee, welche weiteren Änderungen notwendig sind, damit das Plugin auf 4.8.x läuft?

Vielen Dank.

Horst Wiese
Beiträge: 28
Registriert: Do 28. Mai 2009, 06:55
Wohnort: Bremen

Umfrage unter 4.8.12.

Beitrag von Horst Wiese » Mo 21. Dez 2009, 11:09

Guten Tag,

Ich hab das gleiche Problem, gibts da schon ne Lösung?
sherman hat geschrieben:Ich habe versucht das plugin unter 4.8.12 zu installieren und bekomme auch den Fehler bei der Installation:

Fatal error: Class 'Contenido_Security' not found in /homepages/20/d264180393/htdocs/testcms/contenido/classes/class.cec.php on line 68

Habe schon - wie von oldperl - beschrieben die Konstante definiert (define("CON_FRAMEWORK", true);).

Hat jemand eine Idee, welche weiteren Änderungen notwendig sind, damit das Plugin auf 4.8.x läuft?

Vielen Dank.
Dank auch von mir.

rethus
Beiträge: 1843
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von rethus » Do 25. Feb 2010, 11:27

Gleiche Problem hier, als ich gerade ein Plugin installieren wollte.

Und Antwort darauf:

Scheinbar ist es wichtig, dass der folgende Code ganz oben in der Datei steht:

Code: Alles auswählen

if (!defined("CON_FRAMEWORK")) {
    define("CON_FRAMEWORK", true);
}

// include security class and check request variables
include_once ('../../classes/class.security.php');
Contenido_Security::checkRequests();
Ich hatte den include und den Contenido_Sequrity::-Funktionsaufruf unter dem include von "Startup und config stehen, da ging es nicht. nun geht es, wo ich alles nach oben verlagert habe.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable.com: - HighSpeed Hosting, Domains, DomainReselling, Linux-Administration
suther.de: - App-Programierung, High-Performance-Webpages, MicroServices, API-Anbindungen & Erstellung

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Oldperl
Beiträge: 4122
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Eltmann, Unterfranken, Bayern
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von Oldperl » Do 25. Feb 2010, 12:56

rethus hat geschrieben:...nun geht es, wo ich alles nach oben verlagert habe.
Das muss ja auch so sein, da in diesen, von dir genannten, Dateien bereits darauf geprüft wird, ob die Konstante definiert ist, um einen Direktzugriff zu verhindern.

Gruß aus Franken

Ortwin
ConLite 2.1, alternatives und stabiles Update von Contenido 4.8.x unter PHP 7.x - Download und Repo auf Gitport.de
phpBO Search Advanced - das Suchwort-Plugin für CONTENIDO 4.9
Mein Entwickler-Blog

Schimmerlos
Beiträge: 8
Registriert: Di 26. Okt 2010, 13:56
Kontaktdaten:

Re: Plugin: Umfrage

Beitrag von Schimmerlos » Fr 29. Okt 2010, 13:45

Hallo Bender,
http://www.benderwd.de/module/polls.zip:
The requested URL /module/polls.zip was not found on this server.

[Edit]:
OK, habe das hier gefunden:
http://www.suther.de/contenido-modules/skom_polls.zip

Ist das die aktuelle Version?

Gesperrt