con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Alle bestätigten Fehler in CONTENIDO 4.9 (erledigte Fehler werden durch geschlossene Beiträge gekennzeichnet).
Bernbacher
Beiträge: 54
Registriert: Fr 21. Jan 2011, 13:29
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von Bernbacher » Di 26. Sep 2017, 09:18

Sorry, Schreibfehler: ist natürlich 4.9.12 und nicht 4.9.1 :-).

Oldperl
Beiträge: 3920
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von Oldperl » Di 26. Sep 2017, 09:44

Servus,

kein Problem! :wink:
Alternativ mal bei Frederic für die 4.9.13 RC anfragen, näheres in diesem Thread :arrow: https://forum.contenido.org/viewtopic.php?f=98&t=38587
Auch kannst Du versuchen die Klasse cString aus dem GIT zu nehmen. Die Bugbehebungen von Frederic sind zumeist gegen den aktuellen GIT-Zweig gemacht und daher können entsprechende dort bereits vorhandene Änderungen und Einbauten in der 4.9.12 natürlich noch fehlen.

Gruß aus Franken

Ortwin
*NEU* CONTENIDO 4.9 Entwickler-Handbuch
Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x *-* phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9 *-* Mein Entwickler-Blog

rethus
Beiträge: 1775
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von rethus » Di 9. Jan 2018, 14:08

Hab derzeit das gleiche Problem nach einem Upgrade, nur das in der Artikelansicht bei jedem gelöschten Artikel eine unschöne Fehlermeldung ausgegeben wird:
Auswahl_504.jpg
(72.54 KiB) Noch nie heruntergeladen
Ursache liegt darin begründet:
cApiArticleLanguageVersionCollection erbt von cApiArticleLanguageCollection

In Zeile 54 wird dessen create-Methode mit einem Array als Parameter definiert :
https://git.contenido.org/projects/CON/ ... ion.php#54

in der Elternklasse sind dies jedoch einzelne Parameter:
https://git.contenido.org/projects/CON/ ... age.php#83

Im neuen Dev-Branch ist an dieser Stelle noch nichts verändert worden, ein laden von "neueren Zip's" bringt demnach nichts.
Hier muss man sich wohl für eine Variante entscheiden, und diese dann Systemweit umsetzen.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Oldperl
Beiträge: 3920
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von Oldperl » Di 9. Jan 2018, 14:43

Servus,
rethus hat geschrieben:
Di 9. Jan 2018, 14:08
Im neuen Dev-Branch ist an dieser Stelle noch nichts verändert worden, ein laden von "neueren Zip's" bringt demnach nichts.
Hier muss man sich wohl für eine Variante entscheiden, und diese dann Systemweit umsetzen.
Im develop-Branch ist da sehr wohl etwas verändert. Guckst Du hier :arrow: https://git.contenido.org/projects/CON/ ... develop#51
Man muss natürlich auch den entsprechenden Branch vorher wählen... :wink:

Gruß aus Franken

Ortwin
*NEU* CONTENIDO 4.9 Entwickler-Handbuch
Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x *-* phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9 *-* Mein Entwickler-Blog

rethus
Beiträge: 1775
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von rethus » Di 9. Jan 2018, 15:15

Kleine Ursache, große Wirkung :wink: Klassischer Fehler: zwischen Rückenlehne und Monitor.

Für jeden, der exakt diesen Bug beheben möchte, hier der Link zum richtigen Commit, der alle veränderten Dateien beinhaltet:
https://git.contenido.org/projects/CON/ ... 5b4b6bafbb

Danke für die clearification :lol:
1. Commit : https://git.contenido.org/projects/CON/ ... 5b4b6bafbb
2. Commit : https://git.contenido.org/projects/CON/ ... 63a1a0693a
3. Commit : https://git.contenido.org/projects/CON/ ... 1c292d4589
Zuletzt geändert von rethus am Mi 10. Jan 2018, 09:24, insgesamt 4-mal geändert.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

Oldperl
Beiträge: 3920
Registriert: Do 30. Jun 2005, 22:56
Wohnort: Franken, Bayern
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von Oldperl » Di 9. Jan 2018, 15:18

rethus hat geschrieben:
Di 9. Jan 2018, 15:15
Danke für die clearification :lol:
Immer wieder gerne! 8)

Gruß aus Franken

Ortwin
*NEU* CONTENIDO 4.9 Entwickler-Handbuch
Publikation auf medium.com zu meinem angedachten Entwickler-Buch zu CONTENIDO 4.9
ConLite 2.0, alternatives und stabiles Update von Contenido 4.8.x *-* phpBO Search Advanced - das neue Suchwort-Plugin für CONTENIDO 4.9 *-* Mein Entwickler-Blog

rethus
Beiträge: 1775
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von rethus » Di 9. Jan 2018, 15:24

Sehe gerade... die Änderung der Funktion hat auch Auswirkungen auf andere Dateien, in denen der "alte Aufruf mit einzelnen Parametern" noch verwendet wurde.

Beispiel: https://git.contenido.org/projects/CON/ ... evelop#116
Wäre gut, wenn man hier eine Übersicht der Dateien hätte, auf die sich diese Änderung noch auswirkt.

Hab den betreffenden Commit für eine betroffene Datei, die ich gefunden habe nun oben bei der Angabe des anderen Commit ergänzt.
Zuletzt geändert von rethus am Mi 10. Jan 2018, 09:45, insgesamt 1-mal geändert.
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

rethus
Beiträge: 1775
Registriert: Di 28. Mär 2006, 11:55
Wohnort: Mönchengladbach
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von rethus » Mi 10. Jan 2018, 09:24

Kurzer Nachtrag:
Wenn Ihr die Anpassungen aus dem development-Branch nutzt, müsst Ihr auch dafür sorgen, das die neue cString::toLowerCase() Funktion vorhanden ist. Diese wird nun in class.articlelanguage.php verwendet.

Für die Klasse cString wurde jedoch die Vererbungslinie verändert, was wieder weitere Abhängigkeiten mit sich bringt.

Der Vollständigkeit halber hier der Hinweis, das auch folgender Commit vollständig eingepflegt werden muss: https://git.contenido.org/projects/CON/ ... 1c292d4589

Dann sollte es soweit laufen.
Wem das alles zu viel Bastelei für eine blöde "strict-Meldung" ist, der kann getrost auf das nächste Contenido-Release warten :)
Could I help you... you can help me... buy me a coffee . (vielen ❤ Dank an: Seelauer, Peanut, fauxxami )

xstable - Onlineshops, Hosting, Domains und Webentwicklung
suther.de - Webentwicklung, IT-Service, IT-Beratung, Linux-Administration

Software... ein Blick wert: GoogleCalender Eventlist, xst_dynamic_contentType

frederic.schneider_4fb
Beiträge: 963
Registriert: Do 15. Apr 2004, 17:12
Wohnort: Eschborn-Niederhöchstadt
Kontaktdaten:

Re: con 4.9.12: PHP-Warnung Declaration of cApiArticleLanguageVe

Beitrag von frederic.schneider_4fb » Do 11. Jan 2018, 11:46

Diese Anpassungen waren echt "lustig" ;-)
Frederic Schneider
Entwickler bei der four for business AG

Antworten